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EXECUTIVE SUMMARY 

This report is the user manual for the initial release of the computer code DFNGen. DFNGen 
(Discrete Fracture Network Generator Interface) is a graphical user interface for the computer 
code FracGen and several supplementary (“ancillary”) programs developed at the National 
Energy Technology Laboratory (NETL) in Morgantown, West Virginia. 

The intent of DFNGen is to facilitate use of FracGen, to increase the understanding of FracGen’s 
input options and to reduce errors in input. DFNGen is a Windows-based interface, which allows 
for the generation and control of input files using specially-created forms (windows). DFNGen 
runs FracGen as a background process and can analyze the resulting output using a range of 
options. The code also allows the import of input files from prior versions of FracGen. The 
analysis options in DFNGen allow the user to examine fracture length, fracture orientation, scan-
line spacing, and the spatial distribution of fracture center points. 

DFNGen implements a special version of FracGen, termed version 14M (i.e., FracGen version 
2014, modified for current application), which has a revised input format. FracGen 14M, as with 
other versions of FracGen, incorporates three fracture “models” (Model1, Model2, Model3) to 
simulate randomly located fractures, randomly-located swarms or clusters of fractures and 
regularly-distributed cluster zones. Another option (termed Model0) permits the input of fracture 
data collected along boreholes, cores or outcrop scans by the user. Of importance for flow 
modeling, the generated fractures of the network can be subsequently adjusted for varying 
connectivity by several approaches, including synthetic annealing, to facilitate flow modeling 
with a network with a sparse number of fractures. 

This user guide provides an essential, but directed summary of DFNGen operation. For more 
details on FracGen, NFflow, or the ancillary codes, the user is referred to the user guide for these 
codes (NETL, 2014). 
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1. INTRODUCTION 

This report provides a concise description on the use of the DFNGen interface. DFNGen is a 
Windows-Forms based interface1 that facilitates the use of a set of computer codes for the 
generation of discrete fracture networks. In particular, DFNGen facilitates the use of the FracGen 
computer code by gathering and checking input values, formatting input files, running the 
FracGen code in different modes, and performing analyses of the generated fracture network 
with several tools that display and evaluate the fracture network attributes. 

In the initial sections of the manual, the user is introduced to installing the DFNGen program 
(with a listing on system requirements and how to perform an installation), followed by a 
description of the startup process. The startup form (window) is then introduced with a menu 
system that supports the steps needed to conduct all operations. This is followed by a description 
of the basics of defining fracture data as well as importing and exporting input files from prior 
versions of FracGen. 

In Section 4, the manual describes and illustrates the array of menu options that can be selected 
by the user. Six menu options (File – Data – Run – Tools – Analyze – Help) on the startup form 
take the user from developing input file and adding/editing data for stochastic models, to running 
FracGen code and then evaluating the results with several tools that display and analyze the data. 

This manual then follows in Sections 5 and 6 with a more in-depth description on how to specify 
input data using the Layer and Fracture forms and subforms for each fracture generation option. 
The various tabs and options are briefly illustrated for each option, together with some 
elementary input requirements. 

Section 7 describes how to run FracGen in both single-layer and multiple-layer modes and how 
to conduct multiple runs using the same stochastic input descriptions. Further, the various 
methods that can be used to evaluate the output from FracGen are discussed in Section 8, 
including basic instructions on the windows that implement these methods. These methods can: 
1) provide a two-dimensional (2-D) display of the fractures; 2) evaluate fracture length 
distributions; 3) evaluate fracture orientation distributions; 4) count the number of intersections 
for each fracture; 5) compute fracture spacing distances along a user-defined scanlines across the 
network; and 6) display and evaluate the density of fracture center points. 

Finally, a short discussion is provided in Sections 9 and 10 on running the FracOut code (which 
can plot FracGen and NFflow fracture network data) and running a set of supplementary codes 
(labeled as Ancillary Codes) that support FracGen computations or modify FracGen networks. 

Appendices to the report are enclosed for background information including: 

 Listing of the various forms (windows) that the user will encounter in DFNGen (Appendix 
A) 

 Descriptions of the files and file formats used in DFNGen (Appendix B) 

                                                 

 
1  Specifically, DFNGen is a Microsoft© Windows Forms application using .NET Framework GDI+ graphics 

classes, and written in C#. 
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 Parameters used in FracGen 14M for model input (Appendix C) 

 Notes on the specific PC facilities used to develop DFNGen (Appendix D) 

 Descriptions of ancillary codes implemented with DFNGen (Appendix E) 
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2. INSTALLING DFNGEN 

2.1 SYSTEM REQUIREMENTS 

The following computer capabilities are recommended for using DFNGen: 

 Personal computer (PC) with 64-bit operating system, with a dual-core, 2.66-GHz or faster 
processor 

 Video memory of a minimum of 512 MB 

 Microsoft Windows 7 operating system, Service Pack 1 

 True Color or High Color display with a minimum resolution of 1680 x 1050 

 A minimum of 2 GB of total installed random-access memory (RAM)2 

 A minimum of 4 GB of total storage2 

 Installed software for Microsoft’s “.NET Framework 4.0”3 

 Installed “OpenGL” utilities4 

The system can operate on PC’s with fewer capabilities, but the user may experience difficulties. 

2.2 INSTALLATION 

DFNGen file system can be installed either from a data storage device (USB flash drive, CD, 
etc.) or from a common network drive. The user initiates the installation by running the 
setup.exe program under the .\DFNGen Deploy 2014 directory. 

The installation process employs a step-by-step interface requiring only that the user have 
administrative rights to the PC for the installation process. The code can be installed anywhere 
on the computer system where the user has Read-Write privileges5, but it is recommended that 
the code is installed under the user’s \My Documents directory. The code will be installed in a 
directory, DFNGen, together with a subdirectory (.\programs) for FracGen and other related 
programs and files. Before initiating the DFNGen installation, the user should verify that the 
computer has at least 200 MB of free storage space for the code installation in addition to the 
operating requirements. 

                                                 

 
2  Memory and storage recommendations were estimated from code operation with typical fracture networks. 

DFNGen may work satisfactorily on computer systems with less memory or storage, especially if modeling 
is restricted to smaller networks. 

3  This software can be installed from Microsoft’s download center, at URL: 
http://www.microsoft.com/en-us/download/details.aspx?id=17851. 

4  Most PC windows systems sold after mid-1996 will have the OpenGL utilities pre-installed. 

5  The program creates several types of files; if the user does not have Read-Write privileges on the 
installation directory, DFNGen will run, but FracGen-related files cannot be created, and no output or error 
messages are provided. This becomes problematic on network-based PCs especially when installing the 
software in the C:\Program Files or C:\Program Files (x86) directory. 
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To install DFNGen: 

 Go to directory containing the installation program 

 Double-click on the installation program, setup.exe 

 Follow the installation instructions 

To start the program, open the DFNGen folder under the .\programs folder and double click on 
DFNGen.exe. (You can create a shortcut on your desktop by clicking on the DFNGen.exe label, 
selecting the “Create shortcut” option and dragging the shortcut icon to your desktop.) 
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3. GETTING STARTED 

3.1 STARTUP FORM (WINDOW) 

DFNGen is a Microsoft Windows-based program, and uses commands and mouse operations 
typical of such applications. By selecting options using the buttons shown in a window (termed 
here as a “form”), the user will initiate actions, which in many cases will open secondary forms 
to provide for additional data input. (A list of all the forms used in DFNGen is provided in 
Appendix A.) Data is input using both a mouse and the computer keyboard for console-based 
interactions. 

The DFNGen program is initiated by double-clicking on the DFNGen.exe file in the installation 
directory. When running, DFNGen first displays a splash screen, which appears (hangs) for a 
few seconds on the console, and requires no action from the user. This splash form, which 
provides the code version and copyright, is then replaced by the DFNGen Startup form or 
window. At this point, the Startup form (shown in Figure 1) is largely blank and is hiding a 
number of input controls. The hidden controls are to emphasize the need for the user to first 
specify a working directory, or to select an existing DFNGen input file (i.e., a file with an “.fgn” 
extension)6. Upon completing this action, the hidden controls become visible (Figure 2). 

Two additional categories of input are now shown on the form. If the user is starting a new 
analysis, all input boxes on the form will be blank and need to be completed. If starting using an 
existing DFNGen file (such as a provided example file), the input from the file will appear in the 
appropriate boxes, and the user need only complete any undesignated controls. 

Across the top of this form is a set of six menu options (File – Data – Run – Tools – Analyze – 
Help) that allow the user to input data, run various codes and review the results. These menu 
options are discussed in more detail in Section 4. 

3.2 DEFINING FRACTURE NETWORK DATA 

To generate a fracture network using FracGen, various stochastic parameters are required 
depending on the fracture model used.7 As mentioned, if the user selects an existing file as input, 
all values in the input file are translated into the DFNGen system. To input new values for this 
layer, or if the user wishes to edit or confirm the values from a prior file, the user employs the 
menu at the top of the Startup form, selects the “Data” option and then selects the “Define 
Fracturing” submenu option. 

                                                 

 
6  This action will also specify the working directory. 

7  Fracture models and their basis are discussed in more detail in NETL (2014), and only a brief discussion on 
the models is presented in this guide. 
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Figure 1: DFNGen Startup form before selecting a working directory. 

 

Figure 2: DFNGen Startup form after selecting an existing file. 
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The Layer window will now appear (Figure 3). This form provides for input of basic parameter 
values for a layer on the right (i.e., the designated layer number,8 layer thickness, depth and 
selected input units). Fracture sets defined for the layer (if any) are shown in the large box at the 
left of the form using a “TreeView” display in Microsoft Windows Forms. Each layer can 
incorporate several fracture “sets” to define the fracture network across the layer, which appear 
as separate nodes on the tree.9 Each set (node) is based on a single fracture generation option 
(model0, model1, model2, or model3) and stochastic parameters are entered as required for the 
specific model. 

 

 

Figure 3: DFNGen Layer input form. 

At the bottom-left of the form, below the TreeView, are three buttons. The buttons define options 
for controlling fracture sets for the layer. The user can add, delete, or edit existing sets using a 

                                                 

 
8  Each DFNGen file (or set of input parameters in DFNGen) defines only one layer in the subsurface (i.e., a 

2-D horizontal plane which is cross-cut by vertical fracturing). For a single-layer analysis by FracGen, the 
layer number and the total number of layers should be set to 1. When the option of a multi-layer FracGen 
analyses is selected, these parameters become important as described in Section 7.2. 

9  The current maximum number of sets for a layer is 10. 
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simple tree structure shown inside the fracture set box. The specific use of these controls is 
explained in more detail later in Section 6.2. 

Assuming that the user has opened a previous *.fgn file10 with several fracture sets already 
defined, the user can then select one of the set names listed in the TreeView box and then select 
the Edit Set button, and a full fracture form will appear, as shown in Figure 4. 

 

Figure 4: DFNGen Fracture input form after selecting Edit Set. 

The Fracture form overlies the Startup form and Layer form in the background. At the top of the 
Fracture form, the user can designate a name for the fracture set. More importantly, on the 
second line, the generation option is shown. 

  

                                                 

 
10  If just starting out, the user can open an example file provided with the code, provided in the .\input 

examples directory. 
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This selection box allows the user to select one of four options (listed in the drop-down box): 

1. User-Defined Traces/Fractures (Model0) 
2. Define Stochastic Fracture Sets (Model1) 
3. Define Fracture Swarms/Clusters (Model2) 
4. Define Fracture Patterns (Model3) 

This choice affects what is shown on the remainder of the form – the subform, starting with the 
line of tabs directly below the second line. The various tabs and model choices are described 
more in Section 6.3. 

After defining the desired parameters, the user can save the changes by selecting the 
Save & Exit button at the bottom right of the form. The input will be saved, the form will close, 
and the Layer form will now be evident. The user can then exit the Layer form in the same 
fashion. 

If the user does not wish to make a change and discard any changes made on the form, the user 
can close the form by selecting the Cancel button. In this case, if the user has made changes, a 
message box will appear to confirm the action. If the user still wishes to exit without saving (by 
selecting the Yes option in the message box), the message window and the Fracture form will 
simply close. If the user has hit the key by accident, selecting the No option will return the user 
to the Fracture form. 

3.3 USING OTHER FRACGEN FILES - IMPORT AND EXPORT 

DFNGen employs a specific file format for saving layer definitions and running FracGen 14M, 
with each fracture network file having an extension “*.fgn.” This file format differs from (and 
contains more information than) the input files for other versions of FracGen. For cross 
compatibility with other FracGen work, DFNGen has the ability to read (import) the input file 
from other versions of FracGen (i.e., *.dat files), and save the work as a *.fgn file. Conversely, 
DFNGen also has the ability to produce (export) information to a *.dat file format. These two 
options can be accessed from the File menu, under the import and export sub-options. Note that 
in exporting to a *.dat file from DFNGen, some user information is lost. The file format for a 
*.fgn file and the specific data lost in export are discussed further in Appendix B. 

3.4 RUNNING FRACGEN 

After defining the fracture sets for a layer, the user can then generate a 2-D discrete fracture 
network with FracGen, and view the results by selecting the appropriate menu option on the 
Startup form. The menu selections are briefly described in the next section. 
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4. DFNGEN MENU DESCRIPTION 

Various options in DFNGen can be accessed from the menu strip at the top of DFNGen Startup 
form (the first window provided to the user). All top menu items can be selected using the mouse 
or by using a keyboard shortcut (i.e., the Alt key together with the first letter of the menu item 
name; e.g., Alt-F for File operations). 

The top menu allows the user to: 

 Open and close files 

 Define fracture network input and wells 

 Run FracGen and FracOut computer codes 

 Implement ancillary codes to FracGen 

 Analyze the output from FracGen using standard approaches 

 Obtain more information about the Ancillary Tools or contacting the developers 

In selecting a menu item, italics and the greater than (or angle bracket) symbol is used in this 
manual to indicate the menu selection process. For example, File>New, indicates selecting the 
“New” option under the “File” tab from the menu bar. The set of menu options is described in 
more detail in the following sections. 

4.1 FILE 

Selecting the “File” from the top menu provides access to seven file operations, which are 
subdivided into five groups by horizontal lines (Figure 5). These options can be selected using a 
mouse click or by using the control key (Ctrl) and a letter designation; in most cases, the 
designated letter is the first letter of the action (as in Ctrl-O for open) except for “Save-As” 
option, which is implemented with Ctrl-A. 

 

Figure 5: File menu from DFNGen startup form. 

The first File group is for producing a FracGen input file. Selecting the File>New option will 
clear all DFNGen forms, thereby starting a new analysis, and is also typically used to restart the 
DFNGen entry process. The File>Open option will open an existing *.fgn file for the user, using 
a standard Windows file selection process window. Upon choosing a file, all prior input is 
cleared and the new input shown on the DFNGen forms is from the selected file. 
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The second group of options involves saving DFNGen files.11 The File>Save command will 
save the current data set using the current file name and directory path. (If a file name has not yet 
been defined, the user will be prompted to define a file name.) Once a file name and path are 
defined, this option does not allow the user to choose a new file name or alter the path. However, 
the user can create a new file name and new file path under the second option, “Save As.” By 
clicking on File>Save As, the user will be prompted to save the file with a new file name with an 
extension of “fgn”. 

The third group of operations Import and Export (File>Import>*.DAT File and 
File>Export>*.DAT File) provides the import or export of the alternative FracGen files with the 
“dat” extension. The *.dat files were developed for use with other, earlier versions of FracGen, 
and the import/export options in DFNGen allow for compatibility. However, the *.fgn file format 
contains more information (see Appendix B), so exporting a file from DFNGen to the *.dat 
format loses some information and importing the file will leave several fields blank in DFNGen, 
especially on the startup form. No information on fracture definitions will be lost as both formats 
contain the same information in this regard. 

The command in the fourth group, File>Publish, creates a text file which documents the current 
data set using a more user-friendly format and which explains the input values in more detail. 
The command in the fifth and final option, File>Exit, terminates the DFNGen session and does 
not save the current data set. If a “Save” command has not been selected during the DFNGen 
session, selecting the Exit command will first prompt the user to save the file prior to closing. 

4.2 DATA 

Selecting “Data” on the main menu provides the user with two options to define input for 
FracGen analyses (Figure 6). The first option is the “Define Fracturing” option. After selecting 
this item (Data>Define Fracturing), the user is presented with a form to define layer input for 
FracGen. 

As a side note, the data in a single DFNGen file represents the input for one layer or horizon in 
the subsurface. The layer form permits the user to define up to 10 fracture sets for this layer. This 
form is described in more detail in Section 6. 

The second option under the Data menu (i.e., Data>Wells) defines the well characteristics for 
NFflow analyses, which appears at the bottom of the *.fgn file, if defined. Note that well input is 
solely intended for use with NFflow and has no effect on fracture network generation with 
FracGen. 

 

                                                 

 
11  The current version of DFNGen does not automatically save input or create backup files. If the DFNGen 

program closes without saving, the current input on the forms in DFNGen are lost. The user is encouraged 
to backup entry work frequently to prevent loss in the event of a power interruption. 
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Figure 6: Data menu from DFNGen startup form. 

4.3 RUN 

As shown in Figure 7, the “Run” menu provides the user three choices: 1) running FracGen in a 
single layer mode, 2) running FracGen in a multi-layer mode, and 3) running FracOut. Selecting 
the first choice (Run>FracGen - Single) will use the existing values shown in DFNGen forms as 
input and execute the FracGen code to produce a fracture network for a single layer. The 
selection will also create the FracGen output files designated on the Startup form in DFNGen. 
Running a FracGen analysis is discussed further in Section 7.1. 

 

Figure 7: Run menu from DFNGen startup form. 

To model fracture systems in layered rock, FracGen incorporates the option to generate fracture 
systems in several strata (layers) while accounting for fractures crossing from a layer into 
adjacent strata.12 The second menu option (Run>FracGen - Multiple) implements this operation. 
To generate a multi-layer network, the user is first required to develop individual fracture 
network definitions for all layers (i.e., develop a *.fgn files for each layer) prior to selecting the 
option. If the user wishes to use the current fracture network definition, the user must first save 
the input to a *.fgn file. Then, the user can select the DFNGen option to perform a multi-layer 
analysis and will be prompted for the file name of each of the individual layers, starting from the 
bottom up (i.e., the deepest layer is defined first). 

The last option, (Run>FracOut) will start the FracOut code’s user input form. FracOut creates 
graphical displays for both FracGen and NFflow fracture networks. The FracOut form will 

                                                 

 
12  In FracGen, fractures created in one layer can penetrate (extend) upward to one or more the adjacent layers. 
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initially display in the mode to produce a 2-D discrete fracture network from a FracGen fracture 
network file (i.e. from a *.flo file). Hence, to use FracOut, a fracture network file from a 
FracGen analysis must be available for use. FracOut also requires the associated layer definition 
file (*.ldf file) created for the same network. 

4.4 TOOLS 

The “Tools” menu accesses several computer programs that assist in the use or analysis of field 
data as part of developing input for FracGen and NFflow (NETL, 2014). These programs were 
written in Fortran and are implemented by DFNGen as independent executable code, which, 
when selected in DFNGen, run in a separate window and require console input for defining 
input. If the operation of an ancillary code fails, control reverts to DFNGen, without impact to 
DFNGen operations. 

The following ancillary codes are available under Tools menu (shown in Figure 8): 

1. FARM 
2. BHP 
3. Kappa 
4. logSTAT 
5. spa_L 
6. ClusDen 
7. EXPmean 

 

Figure 8: Tools menu from DFNGen startup form. 

Clicking on one of these code options from the Tools menu will start the selected code. These 
codes are described in more detail in the FracGen & NFflow: Naturally-Fractured Natural Gas 
Reservoir Simulator, User’s Guide (NETL, 2014). A summary statement on each code can be 
found under the “Help” menu option in DFNGen. 

4.5 ANALYZE 

The DFNGen “Analyze” menu (Figure 9) provides the user with options to evaluate and view the 
fracture network characteristics using standard statistical charts or figures. In addition to 
providing an image on the console, these forms can provide a bitmap image of the chart or 
figure, and a listing of the selected data in a text file. 
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Figure 9: Analyze menu from DFNGen startup form. 

The Analyze options include: 

1. Display the fractures in the flow region (Analyze>Display Network) 

2. Evaluate the distribution of fracture lengths (Analyze>Analyze Distributions>Length) 

3. Evaluate the fracture orientation distribution using a rose diagram (Analyze>Analyze 
Distributions>Orientation) 

4. Count the number of intersections (Analyze>Count Intersections) 

5. Compute fracture spacing distances along a user-defined scan line (Analyze>Compute 
Scan Lines) 

6. Display and evaluate the density of fracture centers within the flow region 
(Analyze>Determine Areal Density) 

4.6 HELP 

The “Help” menu option (Figure 10) provides the user with options to better understand the 
DFNGen ancillary codes implemented by DFNGen and report concerns on DFNGen operations. 
The first option (Help>Help Topics) will provide the user with a short summary of each of the 
ancillary codes in DFNGen, based on the descriptions in NETL (2014). The second option 
(Help>About) provides a window describing the code version and date, together with a scroll 
box, which contains a brief summary of DFNGen and the contact address to suggest changes and 
report errors. (To see all the text, the user must scroll down using the slider control at the right.) 

 

Figure 10: Help menu from DFNGen startup form. 
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5. DEFINING CONTROL INFORMATION 

5.1 RUN CONTROL AND PROBLEM PROPERTIES 

The initial DFNGen Startup form provides for three categories of input, which apply to the entire 
fracture generation definition. The sections as titled are: (1) Initialize; (2) Controls and (3) 
Problem Definition. The categories appear in bold font on the form (Figure 11).13 

The first, “Initialize,” category provides for the selection of the working directory and or an 
existing *.fgn file as a starting point in problem definition. The working directory is the file 
location where all FracGen external output files are created. By selection of the appropriate 
button (either Browse or Open) the user is presented a standard Microsoft Windows dialog for 
directory or file selection. Upon selection of a working directory, the result is shown below in the 
text box in the next category area. Upon selection of a previously defined file, all information in 
the file will be moved into the DFNGen form and appear in the appropriate boxes. 

The second category of input (“Controls”) directs the output of the FracGen code when executed. 
The topmost control in this group displays the current working directory, which can be changed 
manually by the user. DFNGen allows the user to change the working directory and adjust a 
prior selection at any point during the process of defining the input prior to running FracGen. 
The easiest way to change the working directory is to select the “change” button to the right of 
the directory name. Clicking this button allows the user to select a file name using the typical 
Window’s dialog and save time and errors caused by manual input of a path name. 

Directly below this control is a space for input of a short name, termed “Prefix - Output File 
Names”. This string of characters determines the base name used for all output from FracGen, 
with a different file extension for each file type. For example, if the user inputs a prefix, “gu3”, 
the flow file generated by FracGen will be stored in the working directory with the filename 
“gu3.flo.” and a layer file with the name “gu3.ldf.” To the right of the prefix input box are check 
boxes, which will determine the files output by FracGen; a check indicates that the user desires 
the related file output.14 

Below the prefix definition, the user can select the units for use in the input file generated by 
DFNGen (i.e., *.fgn file). As the NFflow code assumes U.S. (English) units, the user is 
encouraged to output the files with this selection. Note that DFNGen allows for different units 
for different parameters on the various input forms described later; all these values however will 
be converted to the designated output system units when the *.fgn file is generated. 

The two remaining check boxes in this area control special operations of FracGen. The first 
check box indicates the desire to generate a number of different output files with FracGen using 
the same input definition. The number of files sets is identified in the input box to the right. 

                                                 

 
13  A list of all parameters used in FracGen is included in Appendix C. 

14  See Appendix B for a brief description of file types output by FracGen. 
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Figure 11: Control and region input. 

The second checkbox indicates the current definition is one of several “layers” with the total 
number of layers specified by the user to the right.15 

The third category of input (“Problem Definition”) provides for general input for a FracGen 
analyses, including a problem title and the coordinates of the overall flow region to be modeled. 
The title is entered from the keyboard and can be any set of characters designated by the user up 
to a length of 80 characters. 

The coordinates of the flow region assume a rectangular area or plane, using a Cartesian 
coordinate system with x and y axes, with the x-axis as the base or horizontal axis. The region is 
fully defined by input of the lower left x and y coordinates and the upper right x and y 
coordinates. A consistent set of units is assumed, increasing from left to right in the boxes, so 
that a positive area is computed. As an error check, the resulting area is computed by DFNGen 
and shown in the lower right corner of the form shown in a read-only box. If the resulting area is 
positive, the area value is displayed in green. If the coordinates result in a negative area, the area 
value will be shown in a red together with an error message.16 

                                                 

 
15 FracGen allows the creation of several “layers” to represent adjacent strata. A maximum of 5 layers is 

permitted with the current FracGen version. 

16 FracGen performs the same check internally and will stop operation for a negative area value. 
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The boxes for all numeric values in DFNGen incorporate various checks on the characters input 
by the user. For example, on this form, DFNGen allows the input of negative coordinate values. 
As coordinate values can be large, the boxes will also allow input of an exponential number 
(using an exponential in the form of “E+xx”). However, use of extremely large values (in excess 
of +/- 99,999) or the use of any letters will cause an error message to the user, and the current 
textbox will be cleared. 

At the bottom left of the form is a control to select the units for the input values. The units of the 
coordinate values can be elected as either feet, miles, meters or kilometers. 
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6. DEFINING FRACTURING AND WELLS 

6.1 DEFINING LAYER PROPERTIES ON THE LAYER FORM 

To add or edit layer and set properties, the user selects the Data>Define Fracturing at the top of 
the Startup form to display the layer form. As mentioned, this form (shown in Figure 12) 
provides for input basic parameter values for the layer on the right of the form: 1) the layer 
number, 2) layer thickness, 3) depth, and 4) units used. The layer number is to designate the 
current layer position from the bottom of a sequence of layers for multi-layer FracGen analyses. 
For single-layer FracGen analyses, the layer number is set to 1. 

 

Figure 12: Layer information input. 

The layer thickness and depth (of the layer center) are input by the user from the keyboard; the 
text boxes on the form will prevent negative numbers or the use (in general) of non-numeric 
characters except a period. However, the textbox has been structured to allow the use of plus and 
negative signs together with the letter “E” for exponential notation (i.e., in the form xE+xx, 
where x is a number). 

For multi-layer analyses, the user is cautioned to check that the thickness and depth values for 
each layer so they do not indicate an overlap between adjacent layers, as this will cause a 
FracGen error. 

At the lower right of the Layer form (e.g., Figure 12), the user is presented with two control 
buttons: 1) Save & Exit; and 2) Cancel. Hitting the Save & Exit button, the changes made on 
the particular form will be added to the current data base; selecting Cancel button will close the 
form without saving. The user can also exit the form without saving by clicking on the small box 
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at the top-right of the form with the “X” symbol. Note that exiting the Layer form without saving 
will lose all work on the associated fracture sets as well. 

6.2 DEFINING FRACTURE-SETS ON THE LAYER FORM 

On the left side of the Layer form are a fracture set box and a line of buttons, which control the 
definition of fracture sets for the layer. Each layer can use several fracture “sets” to define the 
fracture network across the layer. Each defined fracture set is named and listed in the fracture set 
box. Each fracture set is based on a single fracture generation option (described in the next 
section) and stochastic parameters are entered as required for the specific model. 

When the form is initiated, previously defined fracture sets for the layer (if any) are shown in the 
fracture set box. Control of the fracture sets is performed by selecting an action button at the base 
of the fracture set box. Three options are available: 1) delete a fracture set; 2) add a fracture set; 
and 3) edit a fracture set. To edit or delete a fracture set, the user must first select (highlight) the 
set name shown in the box, and then select the action. 

To delete any fracture set shown for a specific layer, the user selects the set name (i.e., by 
clicking with the mouse directly on the set name), and then selecting the Delete Set button. In 
response, the user is presented with a message window, asking the user to confirm the delete 
action. Selecting the Yes button in the message box will confirm the action; the message box will 
close and the name will be deleted from the fracture set box. Selecting the No button will close 
the message box without any further action. 

To add a set, the user selects the Add Set button. If the user tries to add more than the maximum 
limit of sets, a message box will appear, requiring the user to respond before proceeding. After 
selecting the button, the Fracture form will open 

Similar to deleting, to edit a specific fracture set, the user must first select the fracture set name 
from the list, and then select the Edit Set button. If the user does not first select a set, a message 
box will appear, indicating the error. As with adding a set, after selecting a set and hitting 
Edit Set button, the Fracture form will open. 

Depending on the option selected, the Fracture form will open in one of two modes. If the user 
has selected to add a new set, the Fracture form will hide most controls until the key parameter, 
the “DFNGen Generation Option,” is selected on the second line on the form (see Figure 13). 
Upon defining a set name at the top of form and selecting a generation option (directly below), 
the full form (with the remainder of the controls on the form) will appear. 

If the user has already defined a fracture set, the entire Fracture form will immediately be visible, 
and the information entered and saved in prior sessions will be visible in the appropriate text 
boxes (Figure 14). The full form reveals a subform with a line of tabs just below the top two 
entry lines. Selecting a specific tab will change the subform directly below the tab line. This 
subform, the tabs, and the model generation options are discussed in the next section. 
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Figure 13: DFNGen Fracture input form before selecting a generation option. 
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Figure 14: DFNGen Fracture input form after selecting generation option Model 1. 
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6.3 DEFINING FRACTURE MODEL PARAMETERS ON THE FRACTURE FORM 

The fracture generation selection box allows the user to select one of four options to generate 
fractures17: 

1. User-Defined Traces/Fractures (Model0)18 

2. Define Stochastic Fracture Sets (Model1) 

3. Define Fracture Swarms/Clusters (Model2) 

4. Define Fracture Patterns (Model3) 

Upon selecting a specific generation model at the top of Fracture form, a specific set of tabs is 
presented to the user, just below the generation selection box as part of a subform. These set of 
tabs differs with the model selected, as the tabs are tailored to the selected generation option. 
Several tabs are used for all fracture models (i.e., for options Model1, Model2 and Model3), 
including fracture info, synthetic annealing, correlations, and shift/end control, but specific 
parameters on each of these subforms can vary as required by the model. 

For the first generation option, Model0, only two tabs are shown (see Figure 15)19. The options 
allow for user input of defined fractures either from a separate file or from the keyboard. 
Selecting the “File Data” tab, presents a subform with a text box for entry of the name of the file 
which contains additional user-defined fractures, and a browse button to find the file using a 
Windows query. Selecting the second tab, “User Input – Fractures/Traces” presents a gridded 
entry form for the input of the parameters for each fracture (shown in Figure 15)20. In this case, 
the user selects the Add Line button and enters the available data on the new line on the form. 
The user can move through the form using the arrow keys and a line can be removed by selecting 
the line and selecting the Delete Line button. 

The second option, Model1, provides the user with a set of tabs as shown in Figure 16 (the 
“Fracture Info” tab is selected in the figure). The user can move from subform to subform by 
selecting the desired tab. 

                                                 

 
17  The parameters for each model are described in details NETL (2014); a list of the parameters for these 

models in FracGen 14M is presented in Appendix C. 

18  The option “Model0” provides for the input of fractures from a separate file or from keyboard input. It is 
not a model per se and does not generate a set of stochastic fractures. 

19  As required by FracGen, the Model0 option (if desired) must be the selected for the first set defined for a 
layer and can only be used once. This option, however, is not required to be used, if not needed. 

20  An alternating color scheme for the line input is adopted on the subform. The yellow indicates where the 
next data entry will be displayed. 
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Figure 15: Fracture Model0 tabs (“User Input – Fractures/Traces” tab selected). 

 

Figure 16: Fracture Model1 tabs (“Fracture Info” tab selected). 
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Parameter entry (text) boxes on a subform will also vary with the model selected and only the 
parameters relevant to the selected model are enabled; simply, input for one model option can 
differ from another on a subform with the same tab name. Further, entry boxes may be enabled 
(unlocked) or disabled (locked) based on the user selections during the entry process. 

In more detail, Model1 provides a set of tabs to define all parameters for this model: a) “Fracture 
Info” for fracture set characteristics; b) “Synthetic Annealing” for controls on fracture generation 
and positioning; c) “Correlations” for the parameters defining user-selected correlations; 
d) “Shift/End Control” for fracture intersections/terminations; and e) “User Input – 
Fractures/Traces” for keyboard entry of fracture data.21 

As mentioned, input on all subforms is conditioned to restrict input only into appropriate boxes 
based on selected input options. All other boxes are disabled on the form, depending on input 
options. For example, as shown in Figure 16, selecting a “Uniform” distribution type for fracture 
length (on the “Fracture Info” tab), will disable the “Mean” and “Std (Standard) Deviation” input 
boxes and allow input only into the “Minimum” and “Maximum” boxes immediately to the right 
of the selection. 

In this regard, it is recommended that the user proceed from top to bottom for entry in a subform 
and proceed from left to right along the tab line in selecting tabs for additional input during the 
input process. However, the subforms will allow the user to input data for a specific model in 
any order desired. The user can also change the generation option selected for the entire fracture 
set, which will change the tab set.22 

The set of tabs for Model2 are shown in Figure 17. Two new tabs are introduced (“Cluster Info” 
and “User Input – Clusters”) and one tab is deleted (“User Input – Fractures/Traces”). The 
method of user input for clusters with this model is the same for the fracture input on Model1, 
but the input parameters have changed. Some of the parameters have also changed. 

 

                                                 

 
21  Manual entry of fracture data is similar to the manual data entry for Model0 described earlier. 

22  In this case, data entries in many cases (but not all) will be deleted, and it is recommended that the user re-
examine all entries after changing the generation option, if data have been defined previously for the 
fracture set. 
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Figure 17: Fracture Model2 tabs (“Fracture Info” tab selected). 

The set of tabs for Model3 are shown in Figure 18. The “Cluster Info” for Model2 is replaced 
with the tab, “Cluster Zones” and the “User Input – Clusters” is replaced with “User Input – 
Fractures/Traces”. Again, some of the parameters have changed on the associated subforms for 
the model type. 

 

 

Figure 18: Fracture Model3 tabs (“Fracture Info” tab selected). 

After data entry is completed for a selected generation option, the user selects one of the two 
control buttons on the lower right of the form: 1) Save & Exit; and 2) Cancel (e.g., see 
Figure 14). Hitting the Save & Exit button, the changes made on the particular form will be 
added to the current data base; selecting the Cancel button will close the form without saving. 

6.4 ADDING WELLS 

The aspect of defining wells in the FracGen record is in support of NFflow computations and 
will not influence fracture network generation by FracGen. This form is included for 
completeness in defining a FracGen input file. The Well form is shown in Figure 19. 

The setup of Well form input is straightforward, requiring the definition of the total number of 
wells prior to allowing input of other variables of the well, and definition of the total number of 
laterals for a specific well before allowing the input of information for each lateral. 
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At first, a Well form without input (Figure 19) is locked except for the input box for the total 
number of wells and the units box (both at the top of the form). As a first step, the user should 
specify the units for the data fields using the units box. Then the user can start the input process. 
Input of the total number of wells to be input with this form enables (unlocks) the top half of the 
form on well information. This permits the user to define the basic information for well: the 
location (X-coordinate and Y-Coordinate), radius, depth, and relative depth. 

 

 

Figure 19: Well input form. 

At this point, the user can enter the basic information boxes for Well #1, and then proceed with 
defining the same information for the remaining wells.23 Increasing the count (scroll) box under 
“Current Well Number” provides a new set of text boxes for input; decreasing the count will 
show the prior input. It is recommended that the user first define the well information (i.e., the 5 

                                                 

 
23  A maximum of 50 additional wells is allowed by the current version of FracGen; See Appendix D for array 

limits. 
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input boxes in the middle of the form, but not the total number of laterals for the well) for all 
wells, prior to defining the lateral information. 

After specifying the basic information of each well, the user can proceed to defining the laterals 
for each well. At this point, the lower half of the form on laterals is locked. Before entering any 
data on the lower half of the form, the user must first specify the total number of laterals for the 
specific well.24 This will unlock the lateral input boxes, and the user can enter the information for 
each lateral (X-coordinate and Y-Coordinate, radius, depth, and the layer number in which the 
lateral is located). Again, it is recommended that the information for each lateral is defined 
before moving on to the next well. However, the user can later revisit a well or lateral to specify 
missing data or correct an entry. 

As with other forms, the user can close the form and save the new entries or changes by selecting 
the Save & Exit button, or close the form and discard any changes made on this form by 
selecting the Cancel button. 

 

                                                 

 
24  A maximum of 10 laterals per well is allowed by the current version of FracGen; See Appendix D for array 

limits. 
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7. RUNNING FRACGEN 

7.1 SINGLE-LAYER FRACGEN COMPUTATIONS 

After defining the fracture network parameters for a layer, a FracGen analysis can be performed 
by the user using FracGen 14M. (Details on how this code was modified from version 6 of 
FracGen are provided in Appendix D.) 

The basic operations associated with a FracGen computation are illustrated in Figure 20. Upon 
selecting the Run>FracGen - Single option, the parameters in current DFNGen forms are used to 
construct a single-layer input file, named “input1.txt” in the .\programs directory, and then the 
FracGen code is launched. FracGen will use this file for input. The input1.txt file has the same 
format as a *.fgn file. 

 

Figure 20: FracGen operations logic. 

When FracGen starts its analysis, a small child window appears, indicating that FracGen has 
started (e.g., Figure 21). However, in many cases, especially for single-layer analyses, FracGen 
will conduct the analyses so rapidly that the user may not see it (or if the window is seen, the 
user may be unable to read the text). FracGen then performs a network analysis, and provides an 
output file for use by DFNGen. If an input or run error occurs during the run, FracGen will also 
produce an error log file. For a successful run, FracGen will create the selected external files in 
the user-defined working directory. 

After the completion of the FracGen run, and when DFNGen has resumed control, another child 
window will appear informing the user of completion (Figure 22). After clicking on the OK 
button, the user can then employ the “Analyze” menu options in DFNGen to examine the results 
in the output.txt file, use the reporting files with FracOut, or employ the files with other 
computer codes such as NFflow. 
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Figure 21: FracGen operations window. 

 

 

Figure 22: FracGen successful completion window. 

7.2 MULTI-LAYER FRACGEN COMPUTATIONS 

FracGen provides the option to model the fracture network for several adjacent geologic units 
with each unit described by a single layer file. Fractures in one layer can extend (or penetrate) 
from one layer to an adjacent layer. This is described in more detail in NETL (2014). 

To conduct this multi-layer analysis using DFNGen, the user must first define all the layer files 
for the entire analysis and save each single-layer file as an *.fgn file. The user must indicate on 
each form that a multi-layer analysis is desired by checking (clicking on) the box to the left of 
the text, “Part of a Multi-Layer Description” on the Startup form.25 The user must also indicate 
the total number of layers in the text box to the left of the label, “Number of Layers” on the 
Startup form. Of importance, only when the number of total layers is greater than one (1) on the 
Startup form, will the option boxes related to define fractures penetrating adjacent layers be 

                                                 

 
25  See Figure 2. 
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visible on the Layer and Fracture form.26 

After all the layer files are defined27, the user can then select Run>FracGen – Multiple option 
from the Startup form menu. This will cause a new form to appear, the Multi-Layer form, as 
shown in Figure 23. 

 

Figure 23: Multi-Layer form. 

At the top right of the form is a status display box (to the right of the “Current Run Status” 
label), which displays the current status of the multi-layer analysis. This box will echo the status 
of the analysis process and indicate when a successful FracGen has been performed. 

For the input stage, the first task is to designate the total number of layers28 to be included in the 
analysis in the box near the top of the form. Selecting the desired number of layers will create the 
appropriate number of text boxes at the base of form for file name input. The user then should 
designate the prefix for output files (to the right of the “Output File Name” text). A default name 

                                                 

 
26  The percent penetration is defined under the “Correlations” tab on the Fracture form. 

27  The user can select this option immediately after selecting a working file at the start of a DFNGen session, 
if all the layer files have been previously defined. 

28  A maximum of 5 layers is permitted by the current version of FracGen. 
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“multilayer” is supplied by DFNGen. The fracture network file will have a “.mlt” extension 
instead of “.flo” when generated, to indicate that the file contains more than one layer. 

The next line on the form indicates the current working directory where input files are located 
and where output file will be created. The user can change the working directory by selecting the 
Directory button under the “Actions” heading on the right. The user can exit this form by 
selecting the Cancel button in this same location. 

As the last input step, the user must indicate the layer files to be used in the multi-layer analysis. 
Using the text boxes at the bottom of the form, the user defines the layer files in the order from 
the bottom up, so that the deepest layer is defined first (line 1). The second deepest layer is 
defined as layer 2, etc. 

To assist in defining a file name, selecting the Open button to right of a file name box will open 
a standard Windows file query form, allowing the user to select a file in the working directory. 
After the query window closes, the selected file name will be displayed in the box. Alternatively, 
the user can manually enter the file name and extension in the text box (assuming the working 
directory as the path name). 

Upon completing the file name entry for each box, the user can then select the Run FracGen 
button (under the “Actions” heading) on the form to conduct an analysis. DFNGen will then 
check the file names, check the layer number and total number of layers on each form, and save 
the file as “inputX.txt,” where X indicates the layer number (Figure 20). FracGen will then 
execute using these files for input. 

After the completion of the FracGen run, and when DFNGen has resumed control, another child 
window will appear informing the user of completion, as for the single-layer analysis as shown 
in Figure 22 (if unsuccessful, an error message from FracGen will be in the box). Closing the 
message window, will also close the Multi-Layer form and restore control to the Startup form. 
After a successful completion, an output file with the combined fracture network definitions for 
all layers is available for use with the Analyze menu option. 

7.3 MULTI-RUN FRACGEN COMPUTATIONS 

FracGen can also conduct several sets of analyses using the same input file (a “multi-run” 
analysis). For each analysis or run with FracGen, a different set of variables is selected 
stochastically (as defined by the user parameters). The process of defining the input for a multi-
run run is generally similar to a single-layer computation. One change in the input process is that 
the user must select the option for a multi-run analysis on the Startup Form under the “Controls” 
heading.29 This is accomplished by checking the box to the left of the text, “Output Multiple 
Runs Using Same Input.” The user must also indicate how many runs to perform in the text box 
to the left of the label, “Number of Additional Runs.” 

At this point, the user selects the FracGen single option run (Run>FracGen – Single) from the 
Startup windows menu bar, and the FracGen will conduct the specified number of analyses. As 
for other FracGen analyses, at completion of a successful run, a child window will inform the 

                                                 

 
29  The Controls heading is shown in Figure 2. 
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user (Figure 22). If the run was unsuccessful, the FracGen error will appear in a similar message 
box. After selecting OK, the box will close and restore the Startup window. 

As part of this process, the user should note that each set of output files will be named using the 
prefix label (see Section 5.1) and the run number. Simply stated, if the user inputs “Rock” as a 
prefix, the tenth file set will all be named, “Rock10” with the appropriate file extension. Thus, 
the user is encouraged to use a short prefix label (15 characters or less) for these analyses. In 
addition, prior to selecting this option, the user should ensure that there is sufficient space on the 
file system for the number of files to be created. 

In displaying the resulting network data, the user will be limited to examining the fracture 
network from only the last run with the DFNGen analysis options (Analyze). To examine the data 
from other runs, the user will need to employ FracOut (Run>FracOut) and examine output files 
in the working directory where the multi-run output was created. 
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8. DATA ANALYSIS 

8.1 DFNGEN GRAPHICS 

DFNGen provides several options to analyze the 2-D stochastic fracture network generated by 
FracGen. The graphic displays for these options are based on Windows graphics design interface 
(GDI+) graphics functionality available with Microsoft’s Net Framework 4.5. This graphics 
library was directly incorporated into the C# code generated for DFNGen. 

For each display selected by the user, DFNGen draws the results on the console in real time 
directly for examination by the user. The GDI+ functionality also allows for creating a bitmap 
(*.bmp file) of the image that can be saved by the user. At the top left of each analysis form in 
DFNGen is a Save option, which when selected, will allow the user to save the image shown on 
the console. It will also allow the user to save the underlying subset of the network data used in 
generating the image as a text file. 

8.2 ANALYSIS OPTIONS 

The “Analyze” options incorporated into DFNGen are: 

1. Display the fractures in the flow region 

2. Evaluate the distribution of fracture lengths 

3. Evaluate the fracture orientation distribution using a rose diagram 

4. Count the number of intersections 

5. Compute fracture spacing distances along a user-defined scan line 

6. Display and evaluate the density of fracture centers within the flow region 

With each option, the user can examine single layer and multi-layer analysis results generated by 
FracGen but the forms can only examine one layer at a time.30 However, the user can select a 
specific combination of fracture sets to examine for a selected layer. 

DFNGen uses the “output.txt” file generated by FracGen 14M as the data source for all displays 
for these analyses. This source file is located in the .\programs directory of DFNGen, and 
DFNGen will examine only the current version of this file. If the user has previously conducted a 
FracGen run, the user can examine this network immediately after starting DFNGen by selecting 
the Analyze option from the Startup form menu (without selecting a working directory on the 
Startup form or without having just completed a run with DFNGen) as long as the output.txt file 
is present. DFNGen, however, deletes the output.txt file at the start of every new FracGen 
analysis, so only the most recent data from a successful FracGen analysis can be examined. 
Further, if a FracGen run fails (provides an error message), no output.txt file is generated and the 

                                                 

 
30  For multi-run FracGen analyses, only the last, single-layer network generated can be examined. 
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prior file is no longer available for analysis.31 Selecting an Analyze option when no output file is 
present will produce an error message box. 

The following sections briefly describe and illustrate each analysis option. 

8.3 SELECTING LAYERS AND FRACTURE SETS FOR DISPLAY 

In conducting any analysis option with DFNGen, the user must first select the specific layer to 
display (only one layer is displayed at a time). This choice is provided in the upper left corner of 
each form, using a drop-down scroll box (e.g. Figure 24). Selecting the box will provide a drop-
down list of layers from which to make a choice; the user can select one of the options. The layer 
choices shown; however, are limited to the number of layers in the output source file. 

 

Figure 24: Network display with the Fracture Network form. 

Directly below this box is a set of check boxes and two control buttons (at the upper left of the 
form). The user selects a fracture set for display by checking the check box next to the 
appropriate set number (the order for display is the same as input for the analysis). If all sets are 
desired, the user can check all boxes by selecting the Select All button. Similarly, the user can 
clear all check marks on the form by selecting the Clear button. 

                                                 

 
31  DFNGen does not currently support the ability to save the output file or open a prior output with a different 

file name. 
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8.4 FRACTURE NETWORK ANALYSIS 

DFNGen provides a graphical display of the 2-D network using the Fracture Network form (as 
illustrated in Figure 24). The form is displayed by selecting Analyze>Display Network from the 
Startup form menu. 

Upon form creation, the plot area (the box at the right side of the form) is blank. The user must 
first select the specific layer and some or all of the fracture sets (as used to generate the network) 
of this layer to display. Then the user selects the Plot Sets button (at the lower right of the form) 
to generate an image. 

The plot area rectangle in the display is sized based on the region area so the display is to scale. 
Each fracture is colored based on the fracture aperture value, according to the color scale shown 
at the lower left of the form. The extent of the flow region is also provided numerically in the 
display (left of the color scale), together with the overall density of the network and units of 
fracture length. Also shown along the base of the form, are the number of fractures in the display 
and the time and date of the FracGen analysis run. 

The user can save the results to a graphics format (.bmp file) or to a text file using the Save menu 
option. The user can also select another layer and group of fractures and again select the 
Plot Sets button to realize another result. By selecting the Exit button in the lower right, the user 
closes the form and returns to the Startup form. 

8.5 LENGTH DISTRIBUTION 

DFNGen provides a bar chart of fracture lengths using the Length form (illustrated in Figure 25). 
The form is displayed by selecting Analyze>Analyze Distributions>Length from the Startup 
form menu. 

As for other display forms, the plot area (the box at the right side of the form) is blank upon form 
creation. The user must first select the specific layer and some or all of the fracture sets (as used 
to generate the network) of this layer to display. Then the user selects the Plot Lengths button 
(at the lower right of the form) to generate the chart. 

The total number of fractures shown in the chart and units of fracture length are shown in the 
bottom left corner of the form. In addition, the time and date of the FracGen analysis run are 
shown in the upper right corner. The user can save the results to a file or to a text file using the 
Save menu option. The user can also select another layer and group of fractures and again select 
the Plot Sets button to realize another result. By selecting the Exit button in the lower right, the 
user closes the form and returns to the Startup form. 

8.6 ORIENTATION DISTRIBUTION 

DFNGen provides a graphical display of the fracture orientation of the network using a modified 
rose diagram. The Rose form (illustrated in Figure 26) is initiated by selecting Analyze>Analyze 
Distributions>Orientation from the Startup form menu. 

At creation, the form will display a framework for the rose diagram, with North at the top of the 
form, and 15° grid lines to the east and west for a semicircle (i.e., +/- 90° from North). It may be 
observed that this grid is atypical from a rose diagram frequently used in geospatial analyses. A 
rose diagram is typically a circular polar area plot, which displays the orientation of fractures as 
a circular frequency chart, based on the strike and dip of the fracture. 
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Figure 25: Analyze distribution – fracture lengths with the Length form. 

 

 

Figure 26: Analyze distribution – fracture orientations with the Rose Diagram form. 

However, the fracture network from FracGen is limited to near vertical fractures (i.e., with ~90° 
dip) and actual strike and dip information is not generated. To display fracture orientation, a 
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modified projection is employed; for efficiency, this projection limits the display of orientation 
to the semicircular region of +/- 90° from North. The orientation of a fracture is taken as the 
shorter (absolute) arc measured from North, with + designated as a positive (clockwise) arc.32 

To create an orientation chart, the user must first select the specific layer and specific sets to 
display (as discussed earlier). The user can also modify the range or width of the segments 
displayed on the form. Using the “Divisions” scroll box at the lower left corner of the display 
area, the user can define the width of a division on the rose plot by selecting the size of the 
section in degrees of arc. The user can select 1°, 2°, 5° and 10° of arc for each segment (division 
in the plot. Selecting the Draw Rose button will provide a rose diagram for the parameters 
chosen. 

The rose diagram form will also display the total number of fractures in the distribution and the 
maximum number of fractures in a division (in percent) along the base of the form. The time and 
date of the FracGen analysis run are shown along the top right of the form. 

Again, the user can save the results to a graphics file or to a text file using the Save menu option, 
specify another set of parameters and re-plot the diagram using the Draw Rose or select the Exit 
button to close the form and return to the Startup form. 

8.7 INTERSECTION DISTRIBUTION 

DFNGen provides a frequency chart of the number of fracture intersections along a fracture line 
for all selected fractures, using the Intersection form (illustrated in Figure 27). The form is 
displayed by selecting Analyze>Count Intersections from the Startup form menu. 

As for other display forms, the plot area (the box at the right side of the form) is blank upon form 
creation. The user must first select the specific layer and some or all of the fracture sets to 
display. Then the user selects the Plot Data button (at the lower right of the form) to generate the 
chart. 

A frequency chart is then created, dividing intersection frequency into ten groups, with the first 
nine groups incrementally ranging from 1 to 9, and with the last group of 10 or more (10+) 
intersections. Additional statistics for the chart are shown numerically directly below the plot 
area: total number of fractures and the total number of intersections. In addition, the time and 
date of the FracGen analysis run are shown in the upper right corner. 

As with other forms, the user can save the results to a graphics file or to a text file using the Save 
menu option, specify another set of parameters and replot the diagram using the Plot Data or 
select the Exit button to close the form and returns to the Startup form. 

                                                 

 
32  For example, a generally east-west trending fracture (line) can have an arc of 100° measured clockwise 

from North; it will also make an 80° arc measured counterclockwise. The shorter arc is measured in a 
negative (counterclockwise) direction, and therefore, the fracture is plotted at -80° (80° to the left or west of 
North). 



A User’s Guide to DFNGen 

39 

 

Figure 27: Number of intersections distribution with the Intersection form. 

8.8 SCAN-LINE DISTRIBUTION 

DFNGen provides a fracture-spacing frequency chart along a user defined (scan) line across the 
fracture region using the Scan form (illustrated in Figure 28). The form is displayed by selecting 
Analyze>Compute Scan Lines from the Startup form menu. 

 

Figure 28: Scan line fracture spacing frequencies with the Scan form. 
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For this plot, the user first must select the reference or scan line along which the intersections 
and the spacing’s will be computed. The X and Y coordinates of the two points defining the scan 
line are input using the text boxes at the left of the plot area. The user must also select the 
specific layer and some or all of the fracture sets (as used to generate the network) for the 
analysis. Then the user selects the Plot Data button (at the lower right of the form) to generate 
the chart. 

A frequency chart is then created, dividing the spacing-frequency into ten groups or ranges based 
on the maximum spacing between fractures along the scan line. The spacing statistics for the 
chart are shown numerically directly below the plot area: minimum, maximum, and average 
spacing between fracture intersections along the reference line. In addition, the total number of 
intersections is shown in the lower left corner, and the time and date of the FracGen analysis run 
are shown in the upper right corner. 

As with other forms, the user can save the results to a graphics file or to a text file using the Save 
menu option, specify another set of parameters and replot the diagram using the Plot Data or 
select the Exit button to close the form and returns to the Startup form. 

8.9 FRACTURE CENTER DISPLAY 

This option provides for a graphical display of the fracture centers of fractures of the network. 
The Center form (illustrated in Figure 29) is initiated by selecting Analyze> Determine Areal 
Density from the Startup form menu. The operation and controls used with this form are similar 
to the fracture network form (Network form) described in Section 8.3. 

Upon form creation, the plot area (the box at the right side of the form) is blank. The user must 
first select the specific layer and some or all of the fracture sets (as used to generate the network) 
of this layer to display. Then, the user selects the Plot Centers button (at the lower right of the 
form) to generate an image. 

The center point for each fracture in the selected network is shown with a 10 x 10 grid overlay 
with red lines in the plot area box. The average density of the centers on a per grid block basis is 
provided, together with maximum and minimum density values, the area of each grid block and 
the units used. In this display, the overall plot area rectangle is sized based on the region area, so 
the display is to scale. The number of fractures in the display and the time and date of the 
FracGen analysis run are also shown along the base of the form. 

The user can save the results to a file or to a text file using the Save menu option. The user can 
also select another layer and group of fractures and again select the Plot Centers button to 
realize another result. By selecting the Exit button in the lower right, the user closes the form 
and returns to the Startup form. 
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Figure 29: Areal density of fracture center points with the Center form. 
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9. ADDITIONAL TOOLS - ANCILLARY CODES 

A set of ancillary codes included with DFNGen can be accessed from the Tools menu on the 
Startup form (Tools). As noted Section 4.4, only six of the ancillary codes described in 
NETL (2014) are implemented. All these codes are written in Fortran and compiled separately. 

Upon selecting a menu item, the code will run in a separate window as an independent console 
application (e.g., Figure 30) and will respond only to keyboard input. The user can exit this 
window by clicking on the exit button on the top right of the form (red box with the “X” label), 
or entering control-C from the keyboard. 

The ancillary codes and their implementation are not described in this manual, and the reader is 
referred to NETL (2014) for further details. However, a short description of each of the ancillary 
codes is provided in Appendix E and is available from the Help menu of DFNGen (Help>Help 
Topics). 

 

Figure 30: FARM code analysis window. 
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10. RUNNING FRACOUT 

10.1 GENERAL 

As described in NETL (2014), FracOut is a stand-alone graphics display program originally 
developed by James H. Dean, and modified by Phillip Nicoletti and Seth King. The main body of 
the program was written in Fortran and uses OpenGL, a multi-platform application programming 
interface for rendering 2-D and three-dimensional (3-D) vector graphics. A Windows form 
interface was developed to select the files for plotting and provides controls for changing the 
display output. For the current application, the Windows interface has been modified slightly to 
mate with DFNGen. 

The FracOut program was developed to visually examine the output files from both the FracGen 
and NFflow computer codes. In this regard, the FracOut sub-form has two different modes, 
which change the controls shown on the form: 

1. Aperture plot, which is utilized for, output files from FracGen output files 
2. Pressure plot mode is used to examine NFflow output files 

10.2 IMPLEMENTING FRACOUT 

As employed in DFNGen, FracOut is used to display a fracture network from FracGen using a 
higher resolution graphics package, which allows rotation, and other display options not included 
in the DFNGen analysis options. The user can implement the FracOut code from the DFNGen 
Startup window menu (Run>FracOut). After selecting this menu option, the FracOut form 
appears (Figure 31). The aperture mode of FracOut is shown by default for use with FracGen 
files (as indicated by the radio button at the top of the form), together with the working directory 
path from DFNGen in the “working directory” text box. 

The user first selects the layer description file (*.ldf file) file path to be used for plotting. As with 
other file input, the user can employ a standard Windows query to locate the file by selecting the 
Select File button or input the file name manually from the keyboard (including the entire file 
path to the file). Then, the user must identify the working directory path in a similar fashion by 
selecting the Select Folder button or again from the keyboard. The entire path name is required 
in this case as well. 

Upon selecting the working directory, all available fracture network files (*.flo or *.mlt files) in 
the working directory will appear in the file operation box in the lower half of the FracOut form. 
At this point, the user highlights a file name in this box to plot and selects the Plot button at the 
base of the FracOut form, and three FracOut windows will appear. 

The three FracOut windows shown are: 1) the code operations (Command) window; 2) the Plot 
window; and 3) the Plot Menu. These windows are shown in Figure 32 and 33. The Command 
(console window) displays the operations for FracOut and is not directly manipulated by the user 
to produce/change the graphic plot; it will be displayed in the background. The Plot window 
displays the fracture network in color in the center of the window. The Plot Menu window 
provides a list of keyboard commands that the can used, and the user can close this window at 
any point (the key codes and mouse commands in this window are also shown in Tables 1 and 
2). 
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The user can then change the image in the plot window using the keyboard commands shown in 
the plot menu. For example, the user can use the I and O keys to zoom into or out of the plot 
area. Hitting the Home key will restore the plot to the original view. Right clicking on the mouse 
when over the plot window will echo the coordinates of the mouse cross in the Command 
window. Hitting a number key (1 to 5) will hide or show the fracture data for the respective layer 
number. In addition, a bitmap image of the plot file can also be produced by hitting the B key.33 

After completing an examination of a selected network, the user can exit this display stage by 
closing either the Command window or the Plot window, which is performed by clicking on the 
X on the top right corner of either window. The user can also exit the display stage by selecting 
the Command window, and then hitting control-C. In either case, the Command and Plot 
windows will close and the Plot Menu window will remain open and the FracOut form is on top 
again. The user can then select another file to plot, or change the input to plot another set of files 
in the FracOut form. 

At completion of using FracOut, the user selects the Exit button at the base of the FracOut form. 
This action will close both the FracOut form and Plot Menu form (if visible), and return control 
to the Startup form. 

  

                                                 

 
33  FracOut does not echo the completion of this file operation. The resulting *.bmp file is created in the 

working directory, and the path name is indicated (in whole or part) in the code operations window. 
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Figure 31: FracOut input window. 

 

Figure 32: FracOut operations (Command) window.  
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Figure 33: FracOut Plot and Plot Menu windows. 
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Table 1: Applicable FracOut control commands using keyboard 

Key  Action/Function 

I  Zoom in (+) 

O  Zoom out (‐) 

W  Translate Up 

S  Translate Down 

A  Translate Left 

D  Translate Right 

C  Decrease Z‐exaggeration/Scale 

V  Increase Z‐exaggeration/Scale 

T  Toggle Line/Plane View 

B  Save Bitmap Image 

<  Rotate Counter‐Clockwise 

>  Rotate Clockwise 

Up Arrow  Rotate on X‐axis Clockwise 

Down Arrow  Rotate on X‐axis Counter‐Clockwise 

Left Arrow  Rotate on Y‐axis Clockwise 

Right Arrow  Rotate on Y‐axis Counter‐Clockwise 

Home  Restore Original Plan View 

Number Keys 
(1 to 5) 

Show or Hide Layer (Number) 

 

Table 2: FracOut mouse commands 

Mouse Control  Action/Function 

Left‐Click  Display Coordinates  

Right‐Click  Submenu for Legend 
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11. CONCLUSIONS 

The DFNGen code provides for a Windows-based interface to several computer codes related to 
the discrete fracture network computer program FracGen. As described, DFNGen provides for 
error checking and implements simple controls to develop the input file for FracGen 14M and 
provides analysis tools to examine the resulting fracture network to assist in user understanding. 
It also implements several ancillary codes for related network computations to develop needed 
data or modify the resulting network. Overall, it is concluded that DFNGen can broadly assist the 
novice user with the use of FracGen and support further research of stochastically-generated 
fracture networks in general. 

In the future, it is anticipated that FracGen and DFNGen will be expanded to allow for additional 
fracture generation models (e.g., to simulate semi-parallel joint systems and more complex 
fracture swarms), include non-planar layer geometry, incorporate more high resolution graphics 
capabilities, and perhaps, be expanded to 3-D modeling. 

This document provides only an abbreviated summary of the underlying models in FracGen, and 
the reader is encouraged to become familiar with the FracGen & NFflow: Naturally-Fractured 
Natural Gas Reservoir Simulator, User’s Guide (NETL, 2014) prior to generating any fracture 
system for analysis purposes. The user should also manually inspect the *.fgn files generated by 
DFNGen for any potential errors to provide a second check before relying on FracGen results. 

Please note that DFNGen code and this documentation are provided “As is” without warranty of 
any kind, express or implied, including but not limited to the warranties of merchantability, 
fitness for a particular purpose and non-infringement. In no event shall the authors or copyright 
holders be liable for any claim, damages or other liability, whether in an action of contract, tort 
or otherwise, arising from, out of or in connection with the software or the use or other dealings 
in the software. 

This is the initial issue of the user’s guide for DFNGen. It is expected that this guide and the 
associated software will be modified to further enhance usability, address comments, and to 
correct errors or omissions. Therefore, this guide should be considered a “living document” that 
may evolve over time to reflect the changing circumstances. Comments or suggestions on the 
code or documentation should be provided to c/o Predictive Geosciences Division at NETL. 
Contingent on available resources and budget, as the document and software are refined, its 
interactive role on the NETL website will be used to maintain a living document with routine and 
continual improvement. Hard copy versions of the guide will not be routinely maintained. 



A User’s Guide to DFNGen 

49 

12. REFERENCES 

Bradley, H. B., Gipson, F. W., Eds. Petroleum Engineering Handbook; Society of Petroleum 
Engineers: Richardson, TX, 1987. 

Brown, G. G.; Katz, D. I.; Oberfell, G. B.; Alder, R. C. Natural Gasoline and Volatile 
Hydrocarbons; Natural Gasoline Association of America (NGAA): Tulsa, OK, 1948; p 90. 

Cullender, M. H.; Smith, R. V. Practical Solution of Gas-Flow Equations for Wells and Pipelines 
with Large Temperature Gradients. Transactions, American Institute of Mining, 
Metallurgical, and Petroleum Engineers (AIME) 1956, 207, 281–287. 

McKoy, M. L.; Sams, W. N. Tight gas reservoir simulation: modeling discrete irregular strata-
bound fracture networks and network flow, including dynamic recharge from the matrix. In 
U.S. Department of Energy’s Natural Gas Conference Proceedings, Houston, TX, March 
24–27, 1997; Paper P-17; p 70. http://www.netl.doe.gov/kmd/cds/disk28/ngp17.pdf. 

Mian, M. A. Petroleum Engineering, Handbook for the Practicing Engineer; PennWell 
Publishing Co.: Tulsa, OK, 1992; Vol I. 

NETL. FracGen & NFflow: Naturally-Fractured Natural Gas Reservoir Simulator, User’s 
Guide; Version 14.9; U.S. Department of Energy, National Energy Technology Laboratory: 
Morgantown, WV, 2014. https://edx.netl.doe.gov/dataset/fracgen-and-nfflow-version-14-9. 

Smith, R. V. Practical Natural Gas Engineering. PennWell Publishing Co.: Tulsa, OK, 1983. 

  



A User’s Guide to DFNGen 

50 

 

This page intentionally left blank. 

 

 

 

 

 



A User’s Guide to DFNGen 

A-1 

APPENDIX A: WINDOW FORMS IN DFNGEN 

A.1. General 

DFNGen employs a number of Microsoft forms specially created for input and control. The main 
forms in DFNGen are: 

1. About form: describes the background information for the code 

2. Center form: provides for the display of the centers of generated fractures 

3. FracOut form34: controls the selection of files for running the 3d3.exe code 

4. FracOut control (Command) form34: provides a menu of the control keys for the graphic 
display by 3d3.exe 

5. Fracture form: provides for input of fracture set data for each of the fracture model 
options in FracGen 

6. Help form: provides a short description of the ancillary codes under the Tools menu 
option 

7. Intersection form: provides for the computation of fracture intersections, and bar-chart 
display of results 

8. Layer form: provides for the entry of layer information; it also opens the Fracture form 
for the entry of fracture set data 

9. Length form: for the display of the centers 

10. Multi-layer form: provides for the entry of the layer forms to be used in multi-layer 
FracGen analyses and associated information 

11. Network form: for the display of the network fractures 

12. Rose diagram form: for the display of the fracture orientation (a modified rose diagram) 

13. Scan form: provides for the computation of distances between fracture along a line, and a 
bar-chart display of results 

14. Splash form: provides the user with the version number and copyright 

15. Startup form: main form, which provides for entry of controls flags and the coordinates 
of the flow region, and opens the Layer form and Well form 

16. Well form: provides for the entry of data on wells 

  

                                                 

 
34  Text and formats on the form were modified from original version. 
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APPENDIX B: DFNGEN FILES 

B.1. General 

The files needed for DFNGen operation are briefly described in this section. Files formats used 
for a specific file type defined in FracGen & NFflow: Naturally-Fractured Natural Gas 
Reservoir Simulator, User’s Guide (NETL, 2014) (e.g., with the extension “.flo”) are unchanged 
in use with DFNGen. 

B.2. Input and Output Files Used by DFNGen 

A series of files are related to conducting analyses with DFNGen, FracGen and NFflow. A list of 
the most common files is described in Table B-1. The input file with the extension “.fgn” was 
specially constructed for use with DFNGen, and supersedes the prior FracGen input file with a 
“.dat” extension described in NETL (2014). In addition, the version of FracGen (14M) developed 
for use with DFNGen no longer uses several files as shown in the listing. 

There are also several files created by DFNGen and used by FracGen 14M, which are introduced 
to enable FracGen to operate as a stand-alone executable code in the background. These files 
(see Table B-2) are termed “reserved” as they are created and deleted by DFNGen without direct 
input from the user. The files are located in the .\programs directory in a text format and can be 
viewed using a standard editor. In the event of a computer interruption or crash, the user is 
advised to delete the files before starting new analyses. 

B.3. Application Files Used by DFNGen 

DFNGen implements a number of stand-alone computer codes developed by others 
(NETL, 2014). A list of these programs is shown on Table B-3 and are available under DFNGen 
menu options Run or Tools. 

B.4. *.fgn File Format 

The file format for a *.fgn file (the input file for FracGen 14M) is shown in Figure B-1. The 
FILE format is a free format (column location is not specified) with spaces as delimiters between 
entries. For the most part, the data is structured with a pair of two lines for each input set, with a 
descriptor line followed by an associated data line. For example, in Figure B-1, the first line, 
starting with “FILE IDENTIFICATION: (<= 80 CHARACTERS)” is a descriptor, followed by 
the second line, a data string, “Well GU#3, Single-Layer Model...” On reading this file, the 
FracGen code discards the descriptor line and only retains the pertinent variables on the data line. 

When there are several entries for a single variable set, the format becomes a header line, 
followed by the array of data, with a single set on each line. For example, near the bottom of 
Figure B-1, the line, “  X-LEFT    Y-LEFT   X-RIGHT   Y-RIGHT     WIDTH  SHIFT(%)  
PERCENT” is the descriptor, followed by a several data lines, as for example, “   -2864.1   -
1285.9   -1402.8     730.6  0.000600      0.0       0.0”, with one line of data for a single fracture. 

The general format of the *.fgn file remains constant for each application, with only the data 
lines changing (a “template” type of approach). While this format lends itself to editing an input 
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file with a text editor for another analysis, it can be somewhat confusing for the inexperienced 
user unfamiliar with the parameters. For the user who prefers a more in-depth view, the DFNGen 
code is provided with a series of example problems in the *.fgn format, which have been 
modified from NETL (2014). These can be used as template files for the user with a text editor. 

The *.fgn file format was modified from the *.dat file described in NETL (2014) for the use with 
DFNGen and the modified FracGen 14M. While the data entry lines for model descriptions 
remain the same in both file formats, the initial lines of *.fgn file differ from the *.dat format, as 
highlighted in Figure B-1. 

In more detail, the changes are: 

 At the start of a *.fgn file (after the first two lines for the project title), the *.fgn file 
provides for the input of a reduced set of control flags (previously incorporated in 
FracGen into as a separate file, fracgen.flg) 

 After the control flag input, a pair of lines is included in the *.fgn file to describe the 
prefix variable used to name output files and a pair of lines for input of a default input 
directory 

 The *.fgn format also requires input of a separate flag variable for multiple runs and the 
number of multiple runs desired35 

 The *.fgn file also requires the default units for the FracGen run. As NFflow currently 
assumes U.S. standard (English) units, it is suggested that the user employ these units in 
performing FracGen computations 

 Rather than providing the dimensions of the flow region, the *.fgn format requires the 
user to input the bottom left x-y coordinates and the upper right coordinates of the flow 
area, assuming a rectangular region 

 Finally for multi-layer analyses, the *.fgn format requires the total number of layers in 
the analysis and the current layer number36 

B.5. output.txt File Format 

The file format for the output from FracGen 14M (output.txt) is shown in Figure B-2. It is 
similar to the *.flo file described in NETL (2014) with the exception of the second line which 
contains differing data (highlighted in Figure B-2). 

 

 

                                                 

 
35  The output files created for multiple runs will use the prefix designation and append the run number to the 

name. For example, the 10th simulation with the prefix “GUA”, the flow file output is “GUA10.flo.” 

36  In conducting multi-layer analyses with DFNGen, these lines will be altered in accordance with the input 
form in creating the inputX.txt files used by FracGen to eliminate any numbering errors (where X = 1.n 
files). 
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The second data line is defined as follows, with the variable type in square brackets: 

1. Lower left x coordinate of the flow region [double] 
2. Lower left y coordinate of the flow region [double] 
3. Upper right x coordinate of the flow region [double] 
4. Upper right y coordinate of the flow region [double] 
5. Control flag indicating variable units (0 = us) [integer] 
6. Number of layers [integer] 
7. Run time [string] 
8. Run date [string] 

This file is used by DFNGen for data analysis options, but it was not intended for use outside the 
.\programs directory, and is overwritten with every analysis. If the user wishes to save this file 
format for a specific analysis, the file must be saved in another directory or with a different file 
name in the .\programs directory before starting another FracGen analysis with DFNGen. 
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Table B-1: Files Related to FracGen and DFNGen Codes 

File Name / *.Extension  Description / Purpose 

*.fgn file 
FracGen input file: a formatted text file created and used by 
DFNGen to perform FracGen analyses. File format can be saved and 
opened by DFNGen. The file format is shown in Figure B‐1. 

*.flo file 

Flow network data file created by FracGen, which contains fracture 

data for a single‐layer fracture network.37 File is created in the 

working directory defined by user. 

*.ldf file 

NFflow layer description file created by FracGen to describe the 

upper and lower boundaries of each layer and properties.37 File is 

created in the working directory defined by user. 

*.mlt file 

Flow network data file created by FracGen, which contains fracture 

data for a multi‐layer fracture network.37 File is created in the 

working directory defined by user. Format is similar to *.flo file. 

*.dia file 
FracGen diagnostics file created by FracGen to provide a list of 
network and run diagnostics for the FracGen computation.  

*.dat files 
External text file, employed by prior versions of FracGen for input.37 

Format of this file is similar to a *.fgn file but differs in several 
important aspects.  

fracgen.fi 
File used by prior version of FracGen to define arrays and variables 

as an include file.37 Not used by FracGen 14M. 

fracgen.flg 
File used by prior version of FracGen to define various control 

options.37 Not used by FracGen 14M. 

fracgen.inp 
File used by prior version of FracGen to define last directory used by 

code.37 Not used by FracGen 14M. 

 
. 
 

                                                 

 
37  The file and file format for this file are discussed in FracGen/NFflow User’s Manual (NETL, 2014). 
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Table B-2: DFNGen Reserved and Temporary Files38 

File Name / *.Extension  Description / Purpose 

help.rtf 

Reserved formatted text file, which contains the descriptions of the 
Ancillary computer programs implemented by DFNGen under the 
Menu Tools option. Text is from NETL (2014). File is included in 
DFNGen help form when running. 

Input1.txt 
Reserved file created by DFNGen for input to FracGen 14M for single 
layer analysis. Format is identical to *.fgn files. File is deleted by 
DFNGen prior to the start of each analysis run by FracGen. 

Input2.txt, input3.txt, 
input4.txt, input5.txt 

Reserved files created by DFNGen for input to FracGen 14M for 
multiple‐layer analysis. Format is identical to *.fgn files. Files are 
deleted and replaced by DFNGen prior to the start of each analysis 
run by FracGen. 

output.txt 

Reserved file, created by FracGen 14M, which contains a list of all 
fractures from computation. File is used by analysis options in 
DFNGen under the Menu Analyze option. The file is located in 
.\programs subdirectory, and is deleted by DFNGen prior to the start 
of each analysis run by FracGen. The file format is shown in Figure B‐
2. 

error.log 

Reserved file, created by FracGen 14M if an error occurs. It is a text 
file with two strings, which explain the error encountered. File is 
read and then deleted by DFNGen at the completion of a FracGen 
analysis, if present. Error messages are discussed in NETL (2014). 

prior_directory.txt 
Reserved file created by DFNGen for tracking to define last working 
directory used by code. 

scratchC.dat  Temporary scratch file generated by FracGen. 

scratchF.dat  Temporary scratch file generated by FracGen. 

Fracout.inp 
Reserved file created by FracOut and contains the file path for the 
*.flo and *ldf files used in the prior analysis. 

flowfile.inp 
Reserved file created by FracOut and contains the file path for the 
*.flo file used in the prior analysis. 

resolut.inp 
Reserved file created by FracOut and contain screen resolution 
control parameters. 

 

                                                 

 
38  All reserved files are created and located in the .\programs directory. 
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Table B-3: Executable Files Used by DFNGen39 

File Name / *.Extension  Description / Purpose 

FracGen‐14M.exe 

Modified version of the FracGen code; the original code is described 
by NETL (2014). The code generates a network of discrete fractures 
in 2‐D, to represent a horizontal plane through a series of vertical 
fractures. 

3d3.exe 
Part of the FracOut sequence of codes, the code draws the fracture 
network and allows for manipulation of the image. It is also used for 
depicting NFflow analyses. 

BHP.exe 
Ancillary code. Calculates bottom‐hole static or flowing fluid 
pressures for gas wells from surface static or flowing fluid pressures, 
respectively, using the method of Cullender and Smith (1956). 

ClusDen.exe 

Ancillary code. Calculates various cluster parameters including the 
expected intra‐cluster fracture density (at specified locations along 
the left end of a cluster), correction factors and the intra‐cluster 
fracture center‐point density. 

EXPmean.exe 
Ancillary code. Calculates the geometric mean and shape factor for 
a special truncated exponential distribution given the mean and 
either the minimum or maximum value of the distribution. 

FARM.exe 
Ancillary code. Selects fractures within a region around a well and 
changes the apertures of the fractures within this region. 

Kappa.exe 

Ancillary code. Calculates the fraction (or weight) that upon 
multiplication with the intra‐cluster fracture center‐point density in 
lognormal fracture length distribution provides the weighted 
average center‐point density in the regions of reduced density at 
each end of a cluster. This parameter is the "κ" term in equations 16 
and 17 of McKoy and Sams (1997). 

logSTAT.exe 
Ancillary code. Calculates data statistics including the lognormal 
mean and a lognormal standard. 

spa_L.exe 

Ancillary code. Calculates the frequency of spacing falling within 
defined class intervals and the cumulative percent frequency 
distribution based on the locations of fractures as encountered 
along a one‐dimensional (1‐D) sample line or bore hole. 

                                                 

 
39  All these codes are located in the .\programs subdirectory, and are written and compiled in the Fortran 

computer language.  They are discussed in FracGen/NFflow User’s Manual (NETL, 2014). 
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Note:  

a Lines in red are not included in the *.dat file input. 

Figure B-1: Example of *.fgn File Format. 

 

FILE IDENTIFICATION: (<= 80 CHARACTERS)                                     FRACGEN 14th EDITION 
  Well GU#3, Single-Layer Model 
 COMPUTATION FLAGS - FLAG1 FLAG2 FLAG3 FLAG4 
     1    1    1    0 
 PREFIX NAME FOR OUTPUT OPTIONS 
  gu3 
 WORKING DIRECTORY FOR RUN 
  C:\Users\lindnere\Code\DFNGen\DFNGen Ver 2\input examples\gu3 
 OPTION TO PRODUCE MULTIPLE RUNS WITH SAME INPUT 
     0    0 
 UNIT SYSTEM FOR OUTPUT  0 = US UNITS; 1 = METRIC UNITS 
     0 
 X & Y COORDINATES OF FLOW REGION - LOWER LEFT CORNER 
         0.000        0.000 
 X & Y COORDINATES OF FLOW REGION - UPPER RIGHT CORNER 
     15840.000    15840.000 
 NUMBER OF LAYERS FOR ENTIRE COMPUTATION 
     1 
 LAYER NUMBER 
     1 
 EFFECTIVE DEPTH OF MID-LAYER; EFFECTIVE THICKNESS OF FRACTURED LAYER 
     14509.000      18.000 
 NUMBER OF SETS IN LAYER 
    10 
  MODEL TYPE---------------------------------------------------------- SET 1 
     0 
  SET IDENTIFICATION (< 80 CHARACTERS)>) 
   Fracture Data - Model 0 
  NUMBER OF SAMPLE TRACES (OR BOREHOLES) 
      0 
     X-LEFT    Y-LEFT   X-RIGHT   Y-RIGHT     WIDTH  SHIFT(%) 
 
  NAME OF DATA FILE FOR INTERSECTED FRACTURES 
        
  MODEL TYPE---------------------------------------------------------- SET 2 
     1 
  SET IDENTIFICATION (< 80 CHARACTERS)>) 
   Seismically-resolved faults, interpretation of May 1999 
  FRACTURE ORIENTATION DISTRIBUTION, MEAN AND SDEV (0 = UNI) 
      0      0.00      0.00 
  FRACTURE LENGTH DIST. (0=UNI,1=EXP,2=LOG,3=INT), MIN/MEAN AND MAX/DEV  
      0         0.000         0.000 
  FRACTURE APERTURE DISTRIBUTION, MEAN AND STD DEVIATION 
      0    0.00000000    0.00000000 
  DENSITY OF FRACTURE CENTER POINTS 
    0.0000000000 
  CORRELATIONS (len=F(order), ori=F(len), wid=F(len)) 
       0.00      0.00      0.00 
  MAXIMUM PERCENT FRACTURE SHIFT: MODE I, II, III 
       0.00      0.00      0.00 
  SYNTHETIC ANNEALING CONTROLS (pstart,nswaps,swapl,ifreq) 
     100.00     0     0     0 
  RELATIVE FREQUENCIES OF T-TERMINATIONS (T2,T1) 
       0.00      0.00 
  FRACTURE INTERSECTION FREQUENCIES (%): ZERO TO 10+ INTERSECTIONS 
     0.0   0.0   0.0   0.0   0.0   0.0   0.0   0.0   0.0   0.0   0.0 
  PERCENT FRACS PENETRATING OVERLYING LAYER; CORRELATION TO FRAC LENGTH 
       0.00     0.00 
  NUMBER OF USER-SUPPLIED FRACTURES 
     31 
     X-LEFT    Y-LEFT   X-RIGHT   Y-RIGHT     WIDTH  SHIFT(%)  PERCENT 
    -2864.1   -1285.9   -1402.8     730.6  0.000600      0.0       0.0 
    -1402.8     730.6    1285.9    2717.9  0.000600      0.0       0.0 
     1285.9    2717.9    3214.8    6487.9  0.000600      0.0       0.0 
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Note:  

a Line in red is different in the *.flo file format. 

Figure B-2: Example of output.txt File Format. 

 

Well GU#3, Single-Layer Model                                                    

      0.00       0.00   15840.00   15840.00        0       1    10:49:50    22-Jul-2014 

    X-left    Y-left   X-right   Y-right Aperture  Layer    Set  Number 

     0.000  1767.452  1340.348  2758.144 .600E-03      1      1       1 

  1307.241  2759.610  3204.403  6467.578 .600E-03      1      1       2 

  3097.800  8416.801  3215.965  6468.689 .600E-03      1      1       3 

  3100.496  8422.566  4997.500 12479.101 .600E-03      1      1       4 

  5068.912 12536.079  7744.600 14671.000 .600E-03      1      1       5 

  7756.220 14680.418  9186.902 15840.000 .600E-03      1      1       6 

  1332.492     0.000  2937.945  1786.691 .600E-03      1      1       7 

  3040.154  1901.107  4107.568  4036.034 .600E-03      1      1       8 

  4119.869  4039.884  4179.200  5640.400 .600E-03      1      1       9 

  4179.200  5640.400  4327.925  8349.541 .600E-03      1      1      10 

  4356.201  8354.211  5289.700  9994.900 .600E-03      1      1      11 

  5289.700  9994.900  6517.201 12216.101 .600E-03      1      1      12 

  6517.200 12216.101  7774.080 14729.963 .600E-03      1      1      13 

  6500.651 12205.509 12179.657 15840.000 .600E-03      1      1      14 

  5186.636  9957.584 10374.938 11836.113 .600E-03      1      1      15 

 10283.158 11804.731 14922.634 13391.098 .600E-03      1      1      16 

  5205.018 10004.556  8621.400  9615.000 .600E-03      1      1      17 

  8621.400  9615.000 10930.202  9790.400 .600E-03      1      1      18 

 10933.157  9790.825 15840.000 10494.394 .600E-03      1      1      19 

 11150.030  9758.384 13758.855  9378.426 .600E-03      1      1      20 

  5318.901  6867.901 13900.796  9340.617 .600E-03      1      1      21 

 13893.175  9336.942 15840.000  9959.015 .600E-03      1      1      22 

  4178.163  5639.283  5318.902  6867.902 .600E-03      1      1      23 

  5321.520  6870.080  8621.412  9615.009 .600E-03      1      1      24 

  8706.629  9683.188  9644.201 10433.301 .600E-03      1      1      25 

  9635.477 10431.044 15840.000 12036.089 .600E-03      1      1      26 

 10850.069   610.316 13449.519  4967.868 .550E-03      1      2      27 

 14817.960 10347.848 15840.000 12506.714 .550E-03      1      2      28 

 15188.416 10400.966 15840.000 11269.807 .550E-03      1      2      29 

  9595.660  5333.177 12690.847 10042.852 .550E-03      1      2      30 

  1622.077 11572.345  3496.103 15840.000 .550E-03      1      2      31 

   165.292  7595.937  4984.140 12450.530 .550E-03      1      2      32 

   118.753  1855.226  2459.114  5010.926 .550E-03      1      2      33 

  2466.160  8522.545  4086.849 10531.773 .550E-03      1      2      34 
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APPENDIX C: FRACGEN VARIABLES 

C.1. General 

Table C-1 provides a list of parameters used in FracGen Version 14M to provide operational 
controls, describe the flow region and define the fracture layer. Table C-2 provides a listing of 
the parameters used in the various fracture models, with a filled box indicating which parameter 
is used in the specific model. Note that “Model0” is not a fracture model per se, but rather 
provides for the input of fractures from separate files. 
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Table C-1: FracGen Version 14M - General Parameters 

Parameter Description  FracGen Variable 

General   

Analysis Title/Descriptor  IDheader 

Control Settings: 

Produce Fracture Network File 

Produce Diagnostics File 

Produce layer Description File 

Conduct Multi‐Layer Analyses 

 

Iflag1 

Iflag2 

Iflag3 

Iflag4 

Prefix Text Used in Creating Files  prefix 

Working Directory  WorkingPath 

Control Flag for Multiple Runs  Iflag_multiple 

Number of multiple Runs to Be 
Performed 

Number_runs 

Flow Region   

Bottom Left Corner X Coordinate  xleft 

Bottom Left Corner Y Coordinate  yleft 

Upper Right Corner X Coordinate  xright 

Upper Right Corner Y Coordinate  yright 

Layer Data   

Total Number of Layers in Analysis  numlayers 

Specific Layer Number for Current 
FracGen Run 

layer 

Layer Depth for Current Layer  depth 

Layer Height for Current Layer  height 

Number of Fracture Sets in Current 
Layer 

nsets 
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Table C-2: FracGen 14M - Model Parameters for Each Generation Option 

No.  Parameter Description  FracGen Variable  M
o
d
e
l0
 

M
o
d
e
l1
 

M
o
d
e
l2
 

M
o
d
e
l3
 

1  Sample Traces/Boreholes                

   Number of User‐Defined Traces  ntraces             

  
Intersected Fractures File Path 
(Separate Text File) 

Fracfile             

   Intersected Fractures File ‐ Data 
Ut(j), Uxy(j), ori, Uw(j), Ul(j), 

nstat(j) 
Uo(j) 

           

  
User‐Defined Traces (6 
variables) 

Txl(j), Tyl(j), Txr(j), Tyr(j), 
Tw(j), shift(j) 

           

2  Title               

   Set Identification  heading             

3  Set Orientation               

   Fracture Orientation ‐ Mean  formean             

  
Fracture Orientation ‐ Standard 
Deviation 

sdevfo             

4  Cluster Orientation               

   Cluster Orientation ‐ Mean  cormean             

  
Cluster Orientation ‐ Standard 
Deviation 

sdevco             

5  Fracture Length               

  
Fracture Length ‐ Distribution 
Type 

lendist             

  
Fracture Length Distribution ‐ 
Minimum/Mean Length 
(Parameter #1) 

paramL1             

  
Fracture Length Distribution ‐ 
Maximum/Std. Dev. (Parameter 
#2) 

paramL2             
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Table C-2: FracGen 14M - Model Parameters for Each Generation Option (continued) 

No.  Parameter Description  FracGen Variable  M
o
d
e
l0
 

M
o
d
e
l1
 

M
o
d
e
l2
 

M
o
d
e
l3
 

6  Cluster Length                

  
Cluster Length ‐ Distribution 
Type 

lendistC             

  
Cluster Length Distribution ‐ 
Minimum/Mean Length 
(Parameter #1) 

paramL3             

  
Cluster Length Distribution ‐ 
Maximum/Std. Dev. 
(Parameter #2) 

paramL4             

7  Aperture               

  
Facture Aperture ‐ Mean 
(Parameter #1) 

fwidem             

  
Facture Aperture ‐ Standard 
Deviation (Parameter #2) 

sdevw             

8  Intra‐Cluster Cluster Spacing               

  
Mean Intra‐Cluster Cluster 
Spacing 

spacing             

9  Location/Density               

  
Density of Fracture Center 
Points 

density             

10  Intra‐Crustal Fracture Density               

  
Intra‐Crustal Fracture Density 
‐ Mean 

fracdenm             

  
Intra‐Crustal Fracture Density 
‐ Standard Deviation 

sdevfd             

11  Cluster Density               

  
Density of Cluster Center 
Points 

clusdens             



A Brief User’s Guide to DFNGen 

C-5 

Table C-2: FracGen 14M - Model Parameters for Each Generation Option (continued) 

No.  Parameter Description  FracGen Variable  M
o
d
e
l0
 

M
o
d
e
l1
 

M
o
d
e
l2
 

M
o
d
e
l3
 

12  Clustering Parameters                

   Subzone Partition Control  degX             

  
Longitudinal Position Control 
– Parameter 1 

degY             

  
Longitudinal Position Control 
– Parameter 2 

typeY             

13  Cluster Zone Dimensions               

   Cluster Zone Width  Wz             

   Cluster Zone Length  Lz             

14  Correlations               

  
Length as a Function Order of 
Generation 

rcoefL             

  
Orientation as a Function of 
Length 

rcoefO             

  
Aperture as a Function of 
Length 

rcoefW             

  
Spacing as a Function of 
Length 

rcoefP             

   En‐Echelon Step  latstep             

15  Fracture Shift Modes               

  
Mode I ‐ Maximum Percent 
Fracture Shift 

shf(iset,1)             

  
Mode II ‐ Maximum Percent 
Fracture Shift 

shf(iset,2)             

  
Mode III ‐ Maximum Percent 
Fracture Shift 

shf(iset,3)             

16  Cluster Shift Modes               

  
Mode I ‐ Maximum Percent 
Cluster Shift 

shf(iset,4)             



A Brief User’s Guide to DFNGen 

C-6 

Table C-2: FracGen 14M - Model Parameters for Each Generation Option (continued) 

No.  Parameter Description  FracGen Variable  M
o
d
e
l0
 

M
o
d
e
l1
 

M
o
d
e
l2
 

M
o
d
e
l3
 

17  Synthetic Annealing Controls                

  
Percentage of Fractures 
Generated Before Synthetic 
Annealing Process Begins 

pstart             

  
Target Number of Swaps for 
Each Fracture in Synthetic 
Annealing 

nswaps             

  
Maximum Number of Swaps 
for Each Fracture in Synthetic 
Annealing 

nswapl             

  
Number of Orientation 
Changes Before Translating 
the Fracture Center Point 

ifreq             

18 
Relative Frequencies of T‐

Terminations 
             

   T1 Type  T1             

   T2 Type  T2             

19 
Stipulated Fracture Intersection 

Frequency 
             

   0 Intersection  Ei(iset,1)             

   1 Intersection  Ei(iset,2)             

   2 Intersections  Ei(iset,3)             

   3 Intersections  Ei(iset,4)             

   4 Intersections  Ei(iset,5)             

   5 Intersections  Ei(iset,6)             

   6 Intersections  Ei(iset,7)             

   7 Intersections  Ei(iset,8)             

   8 Intersections  Ei(iset,9)             

   9 Intersections  Ei(iset,10)             

   10 or More Intersections  Ei(iset,11)             
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Table C-2: FracGen 14M - Model Parameters for Each Generation Option (continued) 

No.  Parameter Description  FracGen Variable  M
o
d
e
l0
 

M
o
d
e
l1
 

M
o
d
e
l2
 

M
o
d
e
l3
 

20  Layer Penetration               

  
Penetration of Overlying 
Layers (%) 

perct             

  
Correlation of Penetration to 
Fracture Length (%) 

coefL             

21  User‐Supplied Fractures               

  
Number of User‐Supplied 
Fractures 

numfracs             

  
User‐Supplied Fracture Data 
(7+C3 variables) 

Vxl(j), Vyl(j), Vxr(j), Vyr(j), 
Vw(j), Vs(j), Vp(j) 

           

22  User‐Supplied Clusters               

  
Number of User‐Supplied 
Clusters 

numclust             

  
User‐Supplied Cluster Data (7 
variables) 

Vxl(k), Vyl(k), Vxr(k), 
Vyr(k), Vw(k), Vs(k), Vp(k) 

           

  
User‐Supplied Cluster Zone 
Data (6 variables) 

Wxl(k), Wyl(k), Wxr(k), 
Wyr(k), Wd(k), Ww(k) 
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APPENDIX D: DEVELOPMENT NOTES 

 FRACGEN MODIFICATIONS 

DFNGen implements a modified version of FracGen to conduct analyses. The version used by 
DFNGen (termed, FracGen Version 14M) was modified in 2014 from FracGen Version 6 dated 
April 14, 2004. Note that tracking of computer program version numbers has recently changed 
from sequential numbering to a year-based version numbering; hence the current version is 
designated as 14M. 

The modifications to the FracGen code in version 14M did not impact the computational aspects 
of the code but rather altered only the input and run options of the code. This is to permit 
DFNGen to run the code in a background mode without direct interaction between the two codes. 

Specifically, these changes include: 

 Modification of the input format to read the *.fgn file format rather than the *.dat file 
format 

 Deletion of all console-echo write statements and QuickWin controls 

 Re-direction of all error messages to a new error file 

 Modification of input controls (flags) to reflect external DFNGen control flags 

 Elimination of the separate control file (i.e., fracgen.flg), which defines operational 
control, flags (parameters: iflagA, iflagB, iflagC, iflagD, iflagE, iflagF, iflagG, iflagH 
and iflagQ) 

 Elimination of the separate FracGen include file (i.e., fracgen.fi), which contains the 
dimension of arrays for fracture attributes 

 Change of the file name of the file containing the prior directory from “fracgen.inp” to 
“prior_directory.txt” 

 Addition of subroutines for reading input and producing output, and addition of a 
subroutine to construct time and date strings 

 Addition of variable declarations in most subroutines (and use of the IMPLICIT NONE 
command) to eliminate implicit variable definitions 

 Addition of several comment statements to clarify specific points in code operation 

All changes were written in free format and the resulting code compiled with a Fortran 2003 
complier. 

 FRACGEN LIMITS 

The limits in arrays and input strings in the current version of FracGen are shown in Table D-1. 
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 DEVELOPMENT ENVIRONMENT 

This version of DFNGen was developed on a desktop personal computer running Microsoft© 
Windows 7, Service Pack 3 with an Intel® Xeon® CPU E5-2670, running at 2.6 gigahertz and 
with 16.0 gigabytes of random access memory. Screen resolution is 1920 x 1080. 

The DFNGen code was written in Visual C# as a Windows Form application under 
NetFramework 4, using the Microsoft© Visual Studio Professional 2013 environment, Version 
12.0.21005.1 Release. The Fortran codes used by DFNGen are written in Fortran using Intel® 
Visual Fortran Composer XE 2013 for Windows OS. 

 RUN NOTES 

In performing a new analysis with DFNGen, please note the following: 

 For each new analysis run, the prior output and error files are deleted by the code in the 
directory .\programs 

 Upon starting a new FracGen analysis, the prior input file(s) are overwritten and any 
prior input is lost 

 The output file (output.txt in the .\programs directory) from a prior analysis can be 
accessed by analysis tools before the user starts another FracGen analysis. Therefore, the 
user can start DFNGen and examine prior results without performing a FracGen run. A 
message (warning) box will appear informing the user of this fact. 
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Table D-1: Limiting values in FracGen Ver. 14M 

Parameter Description  Limit 

Maximum Number of Fractures  60,000 

Maximum Number of Layers  5 

Maximum Number of Sets per Layer  10 

Maximum Number of Laterals per Well  10 

Maximum Number of Wells  50 

Maximum Number of User‐Input Fractures per Set  500 

Maximum Number of User‐Input Clusters per Set  500 

Maximum Number of User‐Input Fracture Traces per 
Set 

500 

Maximum Number of Clusters  1,000 

Maximum Number of Fractures in a Cluster  3,000 

Maximum Number of Fracture Intersections Data 

(in File) 
5,000 

Maximum X or Y Coordinate  +99,999.0 

Minimum X or Y Coordinate   ‐99,999.0 

Maximum Number of Characters in Project Title  82 

Maximum Number of Characters in Working Path 
Directory Name 

80 

Maximum Number of Characters in Prefix for Output 
Files 

20 

Maximum Number of Characters in Path File Name for 
Output Files40 

105 

 
  

                                                 

 
40 Note that the file path name (string) limit is the sum of (a) the maximum directory length, (b) the maximum 

prefix length and (c) five additional characters: four for the file extension (e.g., ”.ldf”) and one for the 
directory character (\). 
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Table D-2: Limiting values in DFNGen41 

Parameter Description  Limit 

Target Number of Swaps for Each Fracture in Synthetic 
Annealing 

200 

Maximum Number of Swaps for Each Fracture in 
Synthetic Annealing 

250 

Number of Orientation Changes Before Translating the 
Fracture Center Point 

10 

 
 

                                                 

 
41  These limits apply in DFNGen in addition to those shown in Table D-1. 
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APPENDIX E: DESCRIPTION OF ANCILLARY CODES 

E.1. General 

DFNGen employs a number of smaller supplemental programs (termed “ancillary codes”) 
developed by others at NETL. Descriptions of these codes are (NETL, 2014): 

FARM This program selects fractures within a rectangular region around a well and 
changes the apertures of the fractures within this region. Alternatively, the fracture 
apertures can remain unchanged (reduction factor = 1.0), but in either case, the 
fractures that intersect the region's borders are segmented. Each segment is given a 
common endpoint at the borders of the rectangular region. Fractures intersecting the 
well can also be added to simulate hydraulic stimulation. The user must first supply 
the name of the fracture network file. Parameters for aperture changes and fractures 
can be input in several ways. 

BHP This program calculates bottom-hole static or flowing tubing pressures for gas wells 
from surface static or flowing tubing pressures, respectively, using the method of 
Cullender and Smith (1956) plus the SAREM subroutine, which calculates the Z-
factors.42 The basic input data plus the flow rate and well head pressure pairs can be 
listed within an input data file. A template file exists with the input format. For 
injection wells, the flow rates are negative to indicate flow down the well bore. 
Data values are space delimited. Alternatively, basic input data can be supplied at 
prompts. No corrections exist for: 

 Slugs of liquids in the tubing 

 Nonlinear temperature distributions 

 Variations in gas composition 

 Condensates 

 Changes in tube or casing diameter with distance down the borehole 

 Tubing or casing not extending to the pay zone 

 Changes in well orientation with down-hole distance 

The flow rate is assumed to be based on a standard volume of gas measured at 
14.65 psia and 60°F. At the user-prompts, pseudocritical temperature and pressure 
can be supplied by default (with a null input) using the empirical correlations of 
Brown et al. (1948). At the user-prompts, the Cullender and Smith Method friction 
factor “Fr”, can be supplied by default (with a null input or with zero) from either 
the Nikuradse equations or from the Cullender-Smith equation that uses the Moody 
friction factor. These defaults assume an absolute pipe roughness of 0.0006 inches. 

                                                 

 
42  The compressibility factor (Z), is the ratio of the molar volume of a gas to the molar volume of an ideal gas 

at the same temperature and pressure. 
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The pipe roughness or friction factor can be found for various pipe and annulus 
diameters in the SPE Petroleum Engineer's Handbook, Tables 33.10 and 33.11. This 
program refers to the equations and method as presented in Mian (1992). 

Kappa This program calculates the fraction (or weight) that upon multiplication with the 
intra-cluster fracture center-point density in the kth cluster of Model 2 (lognormal 
fracture length distribution) gives the weighted average center-point density in the 
regions of reduced density at each end of a cluster. This fraction or weight is 
labeled as “κ” (kappa) in equations 16 and 17 of McKoy and Sams (1997), and is 
presented in its mathematical form in equation 18 of the same report. This program 
also calculates fracture length at 3.0, +2.0 and +3.0 standard normal deviates, and 
the program may be used to quickly calculate these values. Kappa applies only to 
lognormal fracture length distributions. 

logSTAT The program calculates a lognormal mean and a lognormal standard deviation plus 
several other statistics from the data supplied. The user enters the raw data as 
prompted, along with a “correction factor”. The correction factor is any multiplier 
that the user decides to input. Use 1.0 if no correction is wanted. The data is stored 
in a file specified by the user. If a data file already exists, the user can input this 
data file name. 

spa_L This program accepts as input the locations of fractures as encountered along a 1-D 
sample line or borehole and produces as output the frequency of spacing falling 
within defined class intervals and the cumulative percent frequency distribution. 
The spacing is adjusted to account for the sample line running at some angle to the 
mean orientation of the fractures, and the adjusted spacing is normalized to a mean 
spacing of 10 units per event. The user should input the beginning point and the end 
point of the survey line where the survey line does not begin and end on fractures. 
This “wrapping” of the sample line adds another value of spacing to the sample. 
Where the sample line begins and ends on fractures, "wrapping" should not be used. 
Where the orientation of the sample line varies relative to the mean orientation of 
the fracture set, such as where a well bore is curved, correction factors may be 
specified for each fracture. This program also calculates the t-statistic for a 
Student's t-Test, which is used to test whether the sampled distribution of fracture 
locations differs significantly from true random fracture locations. The null 
hypothesis, Ho, is that the fractures are randomly located. The null hypothesis is 
rejected in a two-tailed test if the absolute value of the t-statistic (variable: tSTAT) is 
greater than the critical value, variable: tc. The critical value is looked up in 
subroutine tTABLE. Following the calculations of the t-Test, the program calculates 
the degree of clustering in three ways. These are experimental methods of 
calculating the “degree of clustering”. One method comes from the ratio of the 
sample variance to the maximum possible sample variance (calculated as if all 
fractures are in one interval). The second method is like the first method except it 
uses the ratio of the standard deviations. The third method uses two equations, one 
if the variance is less than the mean (i.e., the sample is more regular than perfectly 
random), and the other if the variance is greater than the mean. This third method 
gives a value ranging from -100.0% for regular (or uniform) fracture locations to 
0.0% for perfectly random locations to +100.0% for highly clustered locations (all 
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fractures in one interval). This method cannot reliably discriminate uniform 
locations from regular locations. The output from this program may be used initially 
to determine which fracture network model to apply. The output is used directly to 
estimate two of the clustering parameters for Model 2 clusters. 

ClusDen The program calculates the expected intra-cluster fracture density (ft/ft2) at 
specified locations along the left end of a cluster having either a uniform, 
exponential, or a lognormal fracture length distribution. It then calculates correction 
factors, variables gamma and νI. After this, the program calculates the intra-cluster 
fracture center-point density either for the mean number of fractures (variable di) 
encountered by an axis-perpendicular sample line (with the standard deviation 
variable sdi = 0.0 in Model 2) or for the number of fractures expected to be 
encountered by an axis-perpendicular sample line across the kth cluster (variable sdi 
> 0.0 and each cluster must be handled individually). If the lognormal mean number 
of fractures per cluster encountered by the sample line or bore hole is used, the 
resulting lognormal mean intra-cluster fracture center point density (variable Dzi) 
value equals the di value that is input to FracGen (and sdi = 0.0 or is estimated). 
Otherwise, the lognormal mean and standard deviation are calculated from the 
intra-cluster fracture center-point density of the kth cluster (Dzik) values for clusters 
encountered by the sample line or borehole. 

EXPmean This program calculates the geometric mean and shape factor λ (lambda) for a 
special truncated exponential distribution whenever the user supplies the mean and 
either the minimum or maximum value of the distribution. The end member value 
of the distribution not supplied by the user is also calculated. 
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